No Nethserver email via Nextcloud Mail app

Thanks but sorry, no, that didn’t work. I also tried with the full server name, still no joy.

Does anyone here have a working NextCloud email? Just wondering!

Can you access to NextCloud log and read if there’s any error?
Also: did you look for errors into postfix log?

Thanks again. No I haven’t looked at these logs. I’ve looked at my Nethserver logs admin page and don’t see one for Postfix nor Nextcloud. I do have IMAP and mail logs. Should I look in either of those?

An update: Found the Nextcloud logs which says

[mail] Fatal: Updating account failed: Server denied authentication.
PUT /nextcloud/index.php/apps/mail/api/accounts/3
from *[public IP address]* by *[MAC address?]* at 2019-09-17T07:28:12+00:00

At least I was able to send a mail, however recieve is still not possible

It worked with following settings:

1 Like

NethServer release 7.7.1908 (final)
Nextcloud 17.0.3

This topic was never marked solved, so not sure if it worked for OP, but I am having errors logging in as well, but a different error.
I have entered the settings as described, but I get “Request failed with status code 500”
and in the NextCloud logs I get;

Horde_Imap_Client_Exception_ServerResponse: You do not have adequate permissions to carry out this operation.

And using which configuration?

exactly as shown by mrmarkuz above.

mailclient in nextcloud has a problem with public mailboxes, nethserver is creating a public junk mailbox wich in my case is causing trouble with some mailclients

It seems the problem still persists. I cannot connect too.

Did you solve the problem?

I added the user with r/w access to the public mailbox via the new admin frontend but still the same error.

“Request failed with status code 500”

The settings used are the same @mrmarkuz used above
Nethserver is fully patched and nextcloud is v18.0.0.10

did anyone ever get a solution to this problem.

seems to be a persistent issue.
i am facing similar issues.

whati want to understand is.

is everyone facing a problem using local ldap, or remote bind on the mail server

Please try the following to set ACLs for public folder and then try again to configure Nextcloud Mail.

doveadm acl set -A Public authenticated lookup read

I found another thread about the Nextcloud error and I think @thorsten is right here:

5 Likes

this fixes the problem.
thanks @mrmarkuz well appreceated.

i am now able to configure emails via manual.
Autodetect still does not work.
also facing similar challenges with outlook, cant configure emails

1 Like

For Outlook autoconfig/autodetect I can recommend the automx module by @danb35, it may work for nextcloud mail too (don’t know).

https://wiki.nethserver.org/doku.php?id=email_autoconfig_module

Other things to check for working autodetect:

  • IMAPS 993 and SMTP 587 port open to the public
  • Configure correct helo host
3 Likes

OP here! I still haven’t got NextCloud Mail working so good to hear about a solution. I disabled NextCloud Mail earlier so to try the solution I went to enable it (Mail 1.1.3). But…

  • This app cannot be installed because the following dependencies are not fulfilled:
  • Server version 17 or lower is required.

My NextCloud for NethServer is 1.9.0.

I want to be sure everything correct is in place before I try the solution!

Where do you see these warnings?

Mail app is downloadable for latest Nextcloud 18:

https://apps.nextcloud.com/apps/mail

nethserver-nextcloud-1.9.0-1 including Nextcloud version 18.0.1 with mail 1.1.3 working here.

1 Like

When I went to the NextCloud apps to reinstall Mail. However, I tried again and installed no problem. Even better I used the command given above and I now have email on NextCloud.

:slight_smile:

Thanks to everyone!

1 Like

Yippiihahhhaaa … das klalalalalappt … Danke schön. Mail in Nextcloud funktioniert nun.

Edit - Translation
Yippiihahhhaaa … that wowowowoworks… Thanky you. Mail in Nextcloud up and running

1 Like