No admin login at Icaro

Hello guys,
I’ve installed icaro successfully and got the login page but I cannot login with user: admin, password: admin.
Should I set it somewhere? I even could not find user admin in the database!

Hi @sunshadow,
welcome to the community.
Did you install icaro with vagrant, like at the howto?

Here are my first steps:

I can’t check at the moment, but if you have installed icaro with vagrant of course you have to look at the database inside vagrant.
@mrmarkuz Do you have the installation running at the moment, to check if the admin user is at the database.

No, I don’t have a running instance anymore.

Many thanks for your prompt response
I’ve managed to get it to work actually. The database account table did have an admin user.
What I did wrong is during provisioning, I set icaro hostname to an FQDN that is not configured on DNS (I just added an entry for it in /etc/hosts to point to icaro VM). I also set all the hostnames of the origins of all other components (i.e. for wax, sun-api, …etc) to the same FQDN. My mistake is I did not add an entry to /etc/hosts on icaro itself, and therefore caddy could not proxy requests to wax and sun-api.

1 Like

Hello Michael,
So reading what you wrote above, I understand that your problem was not resolved, am I right? I also have a similar problem:
In my lab environment, everything is working properly. I was able to create a hotspot and to link dedalo on a Netherserver to it. My dedalo has 3 interfaces one red connected to the Internet and also to icaro, green connected to LAN and the other one connected to the hotspot network.
Any machine on the LAN (green) network does have Internet connection through dedalo (I had to assign an IP address manually though and use dedalo as default gateway, which is required for sure as there is no dhcp service on this segment).
A machine on the hotspot network, whose MAC address has been added to the authenticated device MACs on icaro also has Internet connection, which works as intended.
Another machine on the hotspot network initially has DNS lookups but does not have connectivity to Internet (which I guess is healthy). Trying to access any website on the browser does redirect me to the icaro wings webpage and I see parameters passed in the query string, which is also healthy. Also I see that there are some objects which have been fetched from icaro (using developer tools on the browser). But the Wings captive portal is never displayed, the browser keeps showing a rotating circle forever!

I’ve installed Google chrome hoping the captive portal would work on it. It did not work too but at least it helped find a problem on its developer tools. Chrome was trying to fetch the following URL:
The initiator is actually the vue.js script that is on icaro wax itslelf (vue-resource.esm.js) at line 1082, which is:
The question is why it is failing?
I tried to change different dedalo parameters trying to whitelist all URLs under but that did not help!

It is very late here, I hope I can do more tests tomorrow but I really appreciate your help guys!


My problem was solved with an official not self signed certificate.You have to route port 80 and 443 to the nethserver and install a letsencrypt certificate.

This was my problem without the letsencrypt certificate, the installation from @mrmarkuz with letsencrypt and routed ports 80 and 443 worked fine.


Hi Michael,
I’ve just installed a letsencrypt signed certificate and yes hotspot is now working properly in my lab.


Is captive portal also running now and your problem is solved?

Yes now I can access the captive portal and everything is working as expected.

Many thanks!


Can you mark this topic as solved please.

1 Like