Nextcloud mail app config error

My post was badly formatted : now you have to issue an EHLO command :

Yes, I use Thunderbird and SOGo with no issues.

This is the exact same issue:

This is the code that triggers it:

in /usr/share/nextcloud/apps/mail/vendor/

Have a look at this regarding the NOPERM IMAP error :

Have a look at the maillog to see dovecot errors ?

Nope no activity in maillog when I do tail -f maillog and select the mail app and the ‘an unknown error’ ocurred’.

You can try enabling logging in /usr/share/nextcloud/config/config.php:

and see if /var/lib/nethserver/nextcloud/horde_imap.log gives more info.

Thanks @dnutan.

Strange enough I do not see/get /var/lib/nethserver/nextcloud/horde_imap.log

Maybe the mail app needs to go further in the process to get the log generated.
You can grep or use the log viewer to search for any trace related to the mail account. Also nextcloud.log.

As @pagaille said, the error relates to:

The access control system (e.g., Access Control List (ACL), see
[RFC4314]) does not permit this user to carry out an operation,
such as selecting or creating a mailbox.

    C: f select "/archive/projects/experiment-iv"
    S: f NO [NOPERM] Access denied

Does this happen with another email account?

None of the NS server user accounts work. All encounter the same error.

Same issue as last commenter. Can we resurrect this since it hasn’t been solved?

I have the same problem, but I did not understand how to solve it.
It is clear that the problem is not in the mail application, but on the server.

There are two servers that are the same set up,
na odnom server - rabotayet
na drugom - net

I checked all configs of dovecot, postfix, rspamd server

NethServer release 7.6.1810 (final)
[Nextcloud] 15.0.5

I’ve just tried on our installation, it works out of the box.

Just set the Host to “localhost” and use “user@domain” ads login.

I tried everything localhost,, Ip
“User@domain” “user”
Does not help
Authentication passes normally according to the logs
Mail content is not displayed.
the same error comes out

as I said, I launched two servers
and both set up the same
works on one

server 1 - nextcloud - mail application
connects to server 1 mail
cannot connect to server 2 mail

server 2 - nextcloud - mail application
connects to server 1 mail
cannot connect to server 2 mail

those. to server 2 can not connect from another server too

I have the same version of Nethserver and Nextcloud as @Bulat. I’ve enabled the Nextcloud Mail app and followed the suggestings from @giacomo and @pagaille in setting up my mail account in Settings. I’m getting similar errors related to permission in my Nextcloud Logging. Perhaps @giacomo you had horde installed on your Nethserver previously and that’s why you don’t see the errors we see?

[mail] Error: Horde_Imap_Client_Exception_ServerResponse: You do not have adequate permissions to carry out this operation. at <<closure>>

 0. /usr/share/nextcloud/apps/mail/vendor/ line 4569
    _responseCode(Horde_Imap_Clien ... }}, Horde_Imap_Clien ... }})
 1. /usr/share/nextcloud/apps/mail/vendor/ line 4317
    _getLine(Horde_Imap_Clien ... }})
 2. /usr/share/nextcloud/apps/mail/vendor/ line 4245
    _sendCmdChunk(Horde_Imap_Clien ... }}, [Horde_Imap_Clie ... }])
 3. /usr/share/nextcloud/apps/mail/vendor/ line 1754
    _sendCmd(Horde_Imap_Clien ... }})
 4. /usr/share/nextcloud/apps/mail/vendor/ line 1733
    _status([Horde_Imap_Client_Mailbox {}], 8717)
 5. /usr/share/nextcloud/apps/mail/vendor/ line 4038
    status(["Public"], 8717)
 6. /usr/share/nextcloud/apps/mail/vendor/ line 3590
 7. /usr/share/nextcloud/apps/mail/lib/IMAP/FolderMapper.php line 69
 8. /usr/share/nextcloud/apps/mail/lib/Service/MailManager.php line 87
    getFolders(OCA\Mail\Account {}, Horde_Imap_Clien ... e})
 9. /usr/share/nextcloud/apps/mail/lib/Controller/FoldersController.php line 74
    getFolders(OCA\Mail\Account {})
10. /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 166
11. /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 99
    executeController(OCA\Mail\Controller\FoldersController {}, "index")
12. /usr/share/nextcloud/lib/private/AppFramework/App.php line 118
    dispatch(OCA\Mail\Controller\FoldersController {}, "index")
13. /usr/share/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    main("OCA\\Mail\\Cont ... r", "index", OC\AppFramework\ ... {}, {accountId: "4", ... "})
14. <<closure>>
    __invoke({accountId: "4", ... "})
15. /usr/share/nextcloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ ... {}, {accountId: "4", ... "})
16. /usr/share/nextcloud/lib/base.php line 987
17. /usr/share/nextcloud/index.php line 42

GET /nextcloud/index.php/apps/mail/api/accounts/4/folders
from by 27F9C913-0BE4-497E-BE67-992F307B8378 at 2019-04-18T02:16:51+00:00

Thank you.

No I don’t.

You should asks the Nextcloud forum since the problem is application specific.

1 Like

Thanks @giacomo for the reply. I’ll open a post at Nextcloud or with the Mail App team.

Thank you.

1 Like

For the record, I tried to configure it again here and I got the same error message. It worked for a minute then stopped. Strange issue.

SOLVED : Just disable the shared mailboxes !

The problem is that nextcloud’s client lists all the folders of the server when connecting. That’s all right but for the Public folder the server answers permission denied. (maybe that’s the root cause @giacomo ?)

Here’s the wireshark decode :


Case opened :


It seems strange to me, I tried it with shared mailboxes and it worked …