Nextcloud 18 + Collabora 4.2 + ONLYOFFICE

Nextcloud Hub 18

Nexcloud 18 is out and ready to be tested: https://github.com/NethServer/dev/issues/6039

To install or update Nextcloud:

yum --enablerepo=nethserver-testing install nethserver-nextcloud

ONLYOFFICE

Among all new features, it includes a built-in document server for ONLYOFFICE. If you want to test it:

  • Go Apps page and access Office & text section
  • Download and enable the ONLYOFFICE application
  • Download and enable the Community Document Server application. Please be patient, download and install will take a while.
  • Go to the Settings page and access the ONLYOFFICE application under Administration section
  • Verify the :guilabel:Document Editing Service address already contains the public address of your Nextcloud server

If during Community Document Server installs appears an error like cURL error 28: Operation timed out after 30000 milliseconds with 23900732 out of 305964280 bytes ..., that’s how you can manually install the Document Server:

cd /usr/share/nextcloud/apps
wget https://github.com/nextcloud/documentserver_community/releases/download/v0.1.5/documentserver_community.tar.gz
tar xvzf documentserver_community.tar.gz
rm -f documentserver_community.tar.gz
chown -R apache:apache documentserver_community

Remember to manually enable the application from Nextcloud web interface.

Doc: https://docs.nethserver.org/en/latest/nextcloud.html#onlyoffice

Collabora

We didn’t forget about Collabora, and thanks to @mrmarkuz we already have a release which works with Nextcloud out-of-the-box.
Interested on testing new Collabora 4.2? Just execute:

yum --enablerepo=nethforge-testing update nethserver-collabora

Doc: https://docs.nethserver.org/en/latest/nextcloud.html#collabora-online

Please test and report back!

7 Likes

What happens if you already have onlyoffice (and collabora online) active on current NethServer-nextcloud install? Will it break anything?

If you have Collabora, it should just update it.
If you have ONLYOFFICE … I have no idea :smiley:

update nextcloud (openldap) succesful, update collabora succesfull, install onlyoffice (by hand) successful.

now i have to tune the nextcloud new (+) menu a bit to display different items for document creation from collabora and onlyoffice

i only have changed

wget https://github.com/nextcloud/documentserver_community/releases/download/v0.1.2/documentserver_community.tar.gz

to
wget https://github.com/nextcloud/documentserver_community/releases/download/**v0.1.3**/documentserver_community.tar.gz

otherwise a update is needed and a timeout is following
3 Likes

Cool!

Thank you, I have update the post!

Update went smooth. I did need to uninstall my existing onlyoffice (all done through the GUI) and add the port into the Document Editing Service Address, which wasn’t populated.

3 Likes

That new onlyoffice integration looks super interesting :slight_smile: thanks @giacomo

Haven’t been able to get the OnlyOffice document server to work.

NS based default NC install with LE cert behind a NS proxy on a different local subnet, been running for a while.
Upgrade to 18
Installed OnlyOffice app.
Curl failure on Community Doc Server.
Installed manually as above.
Enabled both apps.
Has been rebooted post install.
When hitting the save button in the NC Admin - Settings - OnlyOffice - Doc Edit Service Address I get the error;
{"reqId":"Xi@Cii5GQDTanrcyuWemJwAAAAo","level":3,"time":"2020-01-28T00:38:34+00:00","remoteAddr":"192.168.148.224","user":"admin","app":"onlyoffice","method":"PUT","url":"/nextcloud/index.php/apps/onlyoffice/ajax/settings/address","message":"HealthcheckRequest on check error: Client error:GET https://hostname.domain.com/nextcloud/healthcheckresulted in a404 Not Foundresponse:\n\n\n\n\n\n nope \n\n","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36","version":"18.0.0.10"}

The fqdn address in the error is a working address but the page it’s accessing is a page in /var/www that I had created long ago that says “nope”, I don’t know where /healthcheck is or what it’s supposed to return and if that’s even the problem with the doc server not working, meaning I placed a docx in the files directory and I can only download it, there’s no option to edit and there’s no option to create anything in the files directory except a text document.

I’ve snapshotted this vm but since the NC files and calendar are still working fine it appears this is just related only to the NC OO apps and it’s probably not necessary for me to restore this server to its previous snapshot.

Any thoughts?

You should askon NC forum.
After a very quick search, I’ve found this: https://help.nextcloud.com/t/onlyoffice-integration-https-certificate-failed/35160

Hope it helps :wink:

1 Like

Ok, I installed Onlyoffice on Nextcloud.

And then?

Right now, he’s opening up my files to me in read-only mode.
What configurations are there to allow me to create and edit documents?

Hi,
I think that only open document format are editable.
Other documents are read-only…

1 Like

Oh ok, another piece of useless software that goes to fill the server for nothing…

EDIT:

It seems to open up old documents in .doc and .xls format in read-only mode.

Those in .docx and .xlsx format also opens them for editing.

I upgraded without issue. I did have to manually follow these steps to get the OnlyOffice to install as I did get the curl error described above. Using Neth with Nexcloud and a Samba4 AD.

2 Likes

@saitobenkei nobody forces you to install onlyoffice or even nextcloud. Your rant on useless options on the server is IMO not appropriate…
In the settings of onlyoffice you can decide which extentions are automagically opened with onlyoffice.

1 Like

Oh, even here you always have to say “how nice is the open source that does everything and more”?
If I have to complain, I complain.

What steps did you follow to uninstall onlyoffice, I do not have onlyoffice in the gui of NS, and it is not available, so not sure what you’re referencing here.
Do I need to reverse all steps here, https://wiki.nethserver.org/doku.php?id=onlyoffice
I am not sure the commands to remove some of those things like nodejs, which is installed with curl, and I am not even sure what version I have of OnlyOffice I have as the instructions are updated.

I am getting an error when trying to save onlyoffice as well. I tried what it says in that thread, but that is how it looks in my config.php already.
I am getting this error, I have tried removing and manually re-installing community_document server multiple times, with no change. I had onlyoffice installed and working previously to upgrading to NC 18, and uninstalled onlyoffice server before upgrading.

HealthcheckRequest on check error: cURL error 7: Failed connect to office.mydomain.com:8082; Connection refused (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

It handles Office Open XML format.
On the file’s contextual menu there’s an option to Convert with ONLYOFFICE.

Currently the following document formats can be edited with this app: csv, docx, pptx, txt, xlsx.

About format conversion:

As the formats are fundamentally different, some data (such as charts, tables, autoshapes or images) and formatting can be lost due to the simple reason that some formats ( csv , txt , etc.) do not support them or treat them differently than OOXML standard does. That is why all the non-OOXML files by default are opened for viewing only, although there is an option to convert the file in the context menu.

https://api.onlyoffice.com/editors/nextcloud

On onlyoffice app settings there are some options to open other formats for editing them with onlyoffice:

Open the file for editing (due to format restrictions, the data might be lost when saving to the formats from the list below).

@giacomo hey, couple things… I got the OO app to work, I had the failure for the curl timeout and noted a couple of things, the app is at 0.1.5 now so that should be changed in your manual download wget line and with that in mind… the doc server updates in the ui will fail, without the error msg about the curl timeout… not sure how that should be addressed going forward.
Also, the /healthcheck failure I had earlier, that’s not the right url, I don’t know how or why it’s auto populated that way, we should put in your guide that the url for the Admin User - Settings - OnlyOffice - Doc Edit Service Addres is;
https://your-public-fqdn/nextcloud/index.php/apps/documentserver_community/

Fixed in the post above.

Me neither, we should fill an upstream issue (I didn’t check if there is already one).