NextCloud 11 and WebDAV

i’m not a nextcloud user so forgive my errors:
i’ve installed ns7 on arubaclud,
configured letsencrypt
installed openldap and created user
installed nextlcoud 11.0.2

i need only webdav to test the new backup :slight_smile:
but, while i can connect to nextcloud via web browser, i can’t connect via app(andorid,linux,win on https://my.domain.org/nextcloud) or webdav (tested with cadaver and nautilius on https://my.domain.org/nextcloud/remote.php/dav/files/USERNAME/ or https://my.domain.org/nextcloud/remote.php/webdav/ )

did i missing something?

tnx

2 Likes

Our architecture changed with nextcloud 11. Now it runs under a php-fpm instance with an apache ProxyPass in front of it. The reason is NC11 wants PHP 5.6 but the upstream Apache instance has mod_php 5.4.

Excluding connection issues, let’s see Apache log files, and application log files.

Edit:

I can reproduce the problem. It is a bug!

I removed the update to NextCloud 11 from the nethserver-updates repository, released today on 2017-04-04 07:19 UTC.

The mirrors are excluded until tomorrow morning (approx 2017-04-05 09:00 UTC) to avoid metadata conflicts.

Before proceeding with the release of NextCloud 11 this bug must be fixed, otherwise any existing WebDAV client cannot connect to the NextCloud instance any more.

Bug filed


I guess we must fix the ProxyPass / URL rewriting configuration for WebDAV calls from Apache to php-fpm.

https://docs.nextcloud.com/server/11/admin_manual/installation/source_installation.html?highlight=fpm#php-fpm-tips-label

any hint is welcome! /cc @dev_team

1 Like

@davidep see comment on github

1 Like

Thank you for the hint! It seems to fix the problem!

I’ve uploaded a package to nethserver-testing. I’ve tested it with the Windows client.

 yum --enablerepo=nethserver-testing update nextcloud

Could you give it a try, too? /cc @quality_team

1 Like

it seems to work for me too.
Connection tested with

  • cadaver
  • nautilius (also if i can’t copy files with space in the name, maybe a limitation? i’ll investigate)
  • app from linux
  • ns7 backup + webdav

anyway since i’m not a nextcloud user i would like to wait tests from someone who better know nextcloud
tnx!

1 Like

it seems a known problem…


so, although I’m not sure what I’m doing :innocent:
i’ve disabled the proxypassmatch line and added to

<Directory "/usr/share/nextcloud">
...
<FilesMatch \.php$>
         SetHandler "proxy:fcgi://127.0.0.1:9000"
</FilesMatch>
</Directory>

now seem to work with files containing spaces…

but… i’ve found that mounting webdav on window
https://docs.nextcloud.com/server/11/user_manual/files/access_webdav.html#accessing-files-using-microsoft-windows
don’t allow me to copy files… i can delete file, create and remove dir…
this problem is present also with proxypass configuration… any idea?
tnx!

edit: on windows using an util like netdrive seems to work well
note that also if the manual says to connect using:
https://example.com/nextcloud/remote.php/dav/files/USERNAME/
i’ve made my test using:
https://example.com/nextcloud/remote.php/webdav/
because it’s only way for me to connect (on win/nautilius/nackupNs7)

2 Likes

ok, this one seems a nc11 bug… if someone is interested, i have tested the patch and works well, and should be included in the next week relase (11.0.3)
more info:


2 Likes

IIUC the only fix to apply is for whitespace (FileMatch+SetHandler)?

yes if you think it’s a valid patch… for me works.
tnx

edit:
and permission on /usr/share/nextcloud/.user.ini

1 Like

Thank you very much, @dz00te! I’ve just uploaded a new package in nethserver-testing with the suggested patches:

yum --enablerepo=nethserver-testing update nextcloud-11.0.2-1.3.gbcd069aa.ns7.noarch

After installing it:

systemctl restart httpd
3 Likes

Good catch folks @dz00te @davidep :+1:

The bugfix has been just released and will be soon available from all mirrors!

:gift: special acknowledgements to @dz00te, for driving me to the solution!

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.