New cockpit "restore data" module not working? --> RTFM :)

NethServer Version: 7.7

I can’t use the restore data module.

The first screen shows this :slight_smile:

But when accessing the restore tab, the first drop list is empty :

Bug ?



I’ve tried but I’m having problems connecting to the sftp server, so I’m unable to verify it.
Backups to nfs, cifs and webdav are working and shown on the list.

The backup has to be named “backup-data”.

Tried again and it does not work with backups done before installing restore data module, but with later backups it works.

Please note that selective restore will be available only for backups executed after the application installation.

excerpt from manual

1 Like

That’s the expected behavior. I thought we had it documented. :slight_smile:
I have notes with the commands needed to re-scan old backups and add them to the list.
Ping me if you need them.


Yes it is in the docs.

1 Like

Apologies for that. I had read the release notes stating that past backups missed the needed information for the restore module to work correctly but the fact that my backup task wasn’t even listed made me think that it was a bug.

It looks like it is working now.

Regarding @mrmarkuz his remark about the fact that the backup task has to be named backup-data it’s still not clear for me what’s the deal about this. The doc is not clear to me either.

1 Like

Just to clarify:

I was fooled by a part of the devel docs that does not describe the new server manager.

Restore from graphic interface

NOTE : this apply only to special backup named backup-data

So I named the backup backup-data and it worked so I thought it’s about the naming.
But it worked because I installed the restore module before as written here.

9 posts were split to a new topic: Cockpit - backup and restore-data not working correctly