Network scanner authentication

printserver
v7
sharedfolders

(Zoltán Polyák) #1

NethServer Version: 7.4.1708
Module: samba

Hi!

One of our partner has some network copier with scanner function. I replaced their old Ubuntu server with NS, the DC working fine, but the scanners can’t acces the shared scanner folder,I always get password error. With the old ubuntu and the samba the copiers worked fine.
What could be wrong?

Thx


(Markus Neuberger) #2

Hi @Zoltan_Polyak,

the shared folder may not be guest writable.
You may also try to use no username/password on scanner.
May be different SMB protocols…


(Zoltán Polyák) #3

User/passwd/folders are okay, tested from PC.

I think there is an authetntication problem, maybe older password format etc


(Zoltán Polyák) #4

I’ve just found this:

Ok, but what is the solutions?


(Zoltán Polyák) #5

http://docs.nethserver.org/en/v7/upgrade.html#shared-folders

But this is not an upgrade, so i don’t have this line in the smb.conf


(Michael Kicks) #6

Could you please publish a screeshot of the scan profile, with auth, connection and server data?


(Zoltán Polyák) #7


(Markus Neuberger) #8

Maybe there’s no backslash allowed in in the smb path.
You may try to share just \\adserver\scan without publikus…

Found in some kyo manual:

Please provide your screenshots in English next time if it’s easily possible :wink:


(Zoltán Polyák) #9

Thanks for your help, but I’m a Kyocera technician too. :slight_smile:
The main proplem is the authentication, so the copier can’t log in…


(Markus Neuberger) #10

Oh, I am not a kyocera technician, sorry for sending you a manual you already know :grin:

Does a guest writable shared folder work?

Are there any “advanced smb settings” you can try?

Are there any log errors?

Do you have your old ubuntu smb.conf?


(Zoltán Polyák) #11

Yes, this is a big sucks! You can’t say that the copier wrong or to old when you are the maintainer of the copier too…
There is no prbolem with the share. The samba works wine as DC, and I can access the scan folder with the kyoscan user from PC.
Wrong username or password in the log, when the copiers try to log in.

Yes, I have the old smb.conf, but I left the hdd in the office, so…


(Markus Neuberger) #12

You don’t want to use a guest share(readable/writable to all) for scanning? Maybe this would work…

:grinning:

Maybe on monday…


(Michael Kicks) #13

Three hints:

  • if it’s not, update to latest firmware the MFP
  • use FQDN instead of the hostname for the server
  • use user@domain.name as username instead of ADDOMAIN\user

(Zoltán Polyák) #14

I’ve tried already everything . But the same…


(Jeroen Visser) #15

Can the scanner handle ftp? If so, I would suggest setting up ftp for the scanner and symlinking or bind mounting the ftp folder somewhere in your samba share.


(Zoltán Polyák) #16

Yes. I’m working on it… Maybe this is the only solution. The only problem I can’t figure out how working the system user authentication. I always get wrong password erro with Total Commander.

http://docs.nethserver.org/projects/nethserver-devel/en/v7/ftp.html


(Jeroen Visser) #17

Make sure ssh is enabled for the ftp user.


(Zoltán Polyák) #18

Ok, I made a new user, enabled the ssh, but still 530 permission denied


(Jeroen Visser) #19

Maybe that was specific to my scenario. Can you anonymize your logs and post them ?


(Zoltán Polyák) #20

What logs?