Network scanner authentication

It’s seems like the user not in the acconts db

It’s interesting. I’ve just put back the ftp to virtual, and I can login with and ftp user, of course not with a system user.

For login with a system user, some changes to the configuration need to be made. I will distill them from my configuration in a bit. Are the accounts coming from a nethserver ad account provider on the same or a different machine, or from the company ad ?

from the same machine machine. This is the only server in the network

K, so my configuration is for active directory on a different nethserver acting as ad account provider.

You might need to adapt it a bit … gonna grab it now.

Could you check if this part is in your config, and if so, if your FTP user is listed in that file ?

# Authentication
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd/user_list

iirc I had to manually add the users for some reason I have not payed enough attention to to not say stupid shit when I continue :wink:

yes and yes

I found a solution, not the safest, but maybe it’ll work. I can’t test it with the copiers now, but with total commander its’s working fine:

  • I made a new share without browseable option
  • guest write/read enabled for this share
  • set the ftp virual-user’s chrootdir to this share
  • I put a shortcut to this share into the publikus share (the original location of the real scan folder)

So everybody can access the scan share across a shortcut. Only promlem is the users have to take care to delete files from here.

1 Like

I’m sorry I didn’t think of that, glad you found it on your own. The ftp and samba users don’t share rights. I had a shared ftp I needed to bind mount.

Maybe you can do something with group rights but I am not knowledgeable enough to assist there without it becoming trial & error :wink:

Edit: come to think of it, I think that is why I used a bind mount and not a symlink.

Edit2: yep

https://www.quora.com/What-are-the-differences-between-bind-mounts-and-symlink-on-Unix

Other hint, straight from another Kyocera MFP.
As far as i can see you are using port 445 to access to samba share.
Would you please try 139?

Other question: do password contain characters different from ASCII Table?

It was the socund thing, what I tired.

No. Normal ASCII

Thanks for everyone, I tested, and it works:

Hope it’s o.k. to jump in.

I tested with a Samsung scanner (Sorry for not using Kyocera :slight_smile:), but it looks very similar.

with this settings:

NS7.4 with AD. Sanning directly to the home directory of the user in domain.tld (scan to SMB).
(Sorry for german screenshot)

Just a thought: What about scan to mail?

@Zoltan_Polyak sorry, was worth the try, but you did your job carefully.
:frowning:

We have some Kyocera MFC here.
We had some problems to configure scan to smb folder share on a Windows 2003 domain,

Our solution was to write carefully with same UPPERCASE and lowercase letters the share in the printer as the share on the server

If your share on server is Scan (With first S letter in UPPERCASE and the rest in lowercase), we have to write exactly Scan with te same S letter in UPPERCASE and the rest in lowercase.