Nethserver-urbackup need testers

Need test please

wget http://download.opensuse.org/repositories/home:kot1grun/CentOS_6/home:kot1grun.repo -O /etc/yum.repos.d/urbackup.repo
yum install http://mirror.de-labrusse.fr/nethserver/nethserver-urbackup/nethserver-urbackup-0.0.2-1.ns6.sdl.noarch.rpm 

you have some db command

# config show urbackup-server 
urbackup-server=service
    BroadcastDiscoveryUDPPort=35623   #allowed to the local network
    FixedIP=                                          #when PublicAccess is set to 'IP', set an IP or a comma separated list
    InternetClientTCPPort=55415             #allowed to the internet and local network
    Name=urbackup                                #can be changed -> https://IP/NewName/
    PublicAccess=private                        #limit the web access to the local network (private, public, IP)
    TCPPorts=55413,55414                     #if you want to change port in the setting (used for cgi and httpd)
    access=none                                    #let the localhost, we use a reverse proxy, instead of tcp55414
    status=enabled                                  #control the service (enabled/disabled)

when you change something do

signal-event nethserver-urbackup-save

after the installation you have two things to do

  • set an admin user in the settings tab
  • the backup folder /var/lib/urbackup is created automatically, set it in the setting tab

optionally you can decide to add the /var/lib/urbackup to the backup of nethserver.

echo '/var/lib/urbackup' >> /etc/backup-data.d/custom.include

Now you can use urbackup at https://IP_NS/urbackup/ (the final / is a mandatory) or go to the dashboard application tab.

At first the reverse proxy is restricted to the local network but it can be opened to a public access or for a specified list of IP (comma separated)

7 Likes

In my case repo doesn’t work this way. Had to cpoy it to /etc/yum.repos.d and change inside file [home_kot1grun] to [urbackup]. then installation worked. config is as discribed above. service was started.
I can access admininterface via //servername.domain:55414. Access via dashboard also works.
url is https://servername.domain/urbackup
hope this first look helps. Well done stephdl! :grinning:

2 Likes

normally you should not be able to raise the port 55414, it is limited to the localhost…can you confirm

Thank for your test and report, I modified accordingly

from local network. But i have shorewall rules to access 55414 from loc and from net?? Remnant from old installation?

Ok now you can change that by

config setprop urbackup-server PublicAccess public
signal-event nethserver-urbackup-save

I would prefer to protect the port 55414 from outside because it is not protected by https.

Your custom rule should be removed

If you need you can say which remote IP is able to reach your backup server

I’m sorry, i think is was my fault. I didn’t remove old urbackup-installation properly. there were old databasentries.
I now removed all databaseenries and all old files and reinstalled nethserver-urbackup.

Now i can’t access via port 55414 anymore. Dashboard access works.

hello @stephdl
my client where detectet, but couldn’t communicate correctly. I had to change fw-rules again.
with this

it worked again. But now it’s possible again to reach urback at port 55414 of course.
Somehow the clients seem to need port 55414.

did you changed the rule for the port 55415 ?

It is the port used to discover internet client, normally I allowed private and public access but in the rule you showed I can see only the private access.

Looking forward to testing it tomorrow. Thanks man you’re awesome.
I’a sure that guys like @adam @dz00te @Ctek @WillZen @ironsky @danielecurto @Enzo @jim @MartinsZB @nas are eager to help with testing.

yes, i changed from “accepet net $FW tcp 55415” to “accept loc $FW tcp 55415”

what it could be interesting it is to test with the port 55413 and 55414 restricted to the localhost and the port 55415 restricted to the local network

thank in advance

I am going to test it in few hours… Thanks @stephdl!

I am also planning to test over weekend (just received second HDD for backup RAID). What would be correct way - to uninstall the previous installation with yum?

@flatspin this is for you. I guess you need to delete packages and urbackup directory under /opt/

I am planning to test over weekend too, but I have to do the test on NS6 or NS7?

For a matter to test it correctly the good way should be a new VM and for now ns6 (apache24 is slightly different than apache22)

@flatspin needed to change some port accesses and I don’t know if it is needed…some reviews and tests are welcome.

Hi had to work hole day with 120%, so sorry for late answer.

I did yum remove urbackup. In /var/urbackup are databases. I deletet them manually, otherwise urback restores old values. Also did ‘config delete urbackup-server’, ‘config delete urback-udp’ and ‘signal-event firewall-adjust’. After that, new urbackinstallation asked again for backup-folder and admin user and no client were stored anymore. So i think it was a real new installation.

2 Likes

hope on monday will have time. New VM ist allready ready.

1 Like

@stephdl did the installation on a new VM NS 6.7 final.
repo is now in right folder, but repo name must be changed to [urbackup] manually.
Urbackup found a client without changing fw-rules and did a backup. :thumbsup:


Everything else seems to work. Good Job!

2 Likes

where is the mega-like button ?

Merci Ralf :slight_smile:

next step could be to test urbackup2 on NS7…this a good reason to test the alpha.

3 Likes