Nethserver trying to Connect to a DomainController

i have installed a NethServer DomainController but i cant connect the client to the Domain i have set the DNS server of the client to the nethserver ip but when i would like to ping the Domain name it says timet out how can help me ?

Hi Jannik,

welcome to Nethserver Community.

Do you use virtualization?

https://docs.nethserver.org/en/latest/accounts.html#installing-on-a-virtual-machine

Are you able to ping the Nethserver IP or the NSDC IP? (the IP you setup at Account Provider installation)

Is the system time correct on server/client?

2 Likes

Yes i am able to ping to the Nethserver ip and the System time is also right

Can you ping the Nethserver Domain Controller IP that you setup during Account Provider installation?

http://docs.nethserver.org/en/v7/accounts.html#samba-active-directory-local-provider-installation

Please check if your domain is resolvable with

nslookup youraddomain.tld

look this http://prntscr.com/o57m5s
the ping to the ip of the DC timet out

Please check if the DC is running on the Nethserver with
systemctl status nsdc

active http://prntscr.com/o5ao2i
and if i ping the dc ip adress from the nethserver it is sucessful but not from the client

1 Like

It’s a typical error if you use Nethserver with virtualization(like KVM, VMWare or Virtualbox):

Please use the following commands and paste your account provider configuration:

config show nsdc
config show sssd

What kind of client do you use? Windows 10? Did you try another client?

Do you use Nethserver with only one green interface or is it working as a gateway? Do the other things work normally (like DHCP, www)?

1 Like

i use only it only on the one green interface an i try it on Win 10 and Win 7 Client and i use virtualbox yes

[root@nethserver ~]# config show nsdc
nsdc=service
IpAddress=192.168.178.68
ProvisionType=newdomain
bridge=br0
status=enabled

[root@nethserver ~]# config show sssd
sssd=service
AdDns=192.168.178.68
BindDN=ldapservice@JANNIK.SITE
BindPassword=
DiscoverDcType=ldapuri
LdapURI=ldaps://nsdc-nethserver.jannik.site
Provider=ad
Realm=JANNIK.SITE
Workgroup=JANNIK
status=enabled

Did you configure virtualbox according to the documentation?

http://docs.nethserver.org/en/v7/accounts.html#virtualbox

yes sure

Here’s an old screenshot showing the important “Promiscuous Mode” setting in virtualbox:

2017-09-09%2022-44-47

i need two adapters right ? i have set it like on the screenshot

No, not necessarily.

You’ll need a bridged interface (instead of host-only) to make it possible for other clients to reach the NSDC on the virtualized Nethserver.

yes i have it bridged

I tested it now with virtualbox 6.0 on win 10 and it finally worked.

Here are the network adapter settings:

grafik

What I did on the Nethserver VM:

  • set static ip for green interface
  • software updates
  • reboot
  • setup ad account provider

At first it didn’t work so I did following steps to make it work but I don’t know what exactly helped:

  • reboot the Nethserver VM or do a systemctl restart network
  • deactivate the VMWare network adapters in the Windows network settings and disable/enable the Virtualbox adapter (I use VMWare too)
  • change the adapter type in the virtualbox network settings to some other card (Intel …) and back again

i did this

I disabled/enabled the firewalls of the systems too. Maybe this did the trick.

On Nethserver you may do

shorewall clear

to disable the firewall and

signal-event firewall-adjust

for reenabling it.

I disabled the Windows firewall on my client too and enabled it again, maybe this resets some local adapters in a way.

For this step you have to shutdown the VM.

grafik

i think now the nethserver has no connection outside because i cant ping sites like google from the nethserver side how i can fix this

Check if the Network settings are correct. If you use a red interface, the gateway has to be entered there.
Does ping google.com work on the Nethserver directly? Do the clients get the right network settings via DHCP?