Nethserver trying to Connect to a DomainController

it is fixed now i can send pings to google

1 Like

If your problem is solved, please mark an answer as solution to help others and close the thread.

no it is not solved the native problem that i cant connect to the domain by client is not solved

if ein want to provision the domain i got this error in the end
Aufgabe mit Fehler abgeschlossen

Template /etc/krb5.conf #35 (Exit Status 1)
    expansion of /etc/krb5.conf failed

Please use following command to see more details about the error:

expand-template /etc/krb5.conf


and the second problem that when i try to add a client i can only use the netbios name not the full domain name and if i want to proceed with the login in the system say domain not found

the krb5 problem is fixed after an update

Is the full domain name resolvable from the client?

Does joining a client to Nethserver work?

Did you use correct login like DOMAIN\User?

It’s recommended to use a subdomain like AD.JANNIK.SITE as AD domain, see https://docs.nethserver.org/en/v7/accounts.html#dns-and-ad-domain

yes it is resolveble by nslookup but i cant ping the ip of the dc directly only the nethserver ip from the client

This is typical for not working/missing “promiscuous mode” in the virtualbox.

You may try to ping the Nethserver and a client from inside the NSDC:

NSDC has no ping so I just copied and removed it afterwards.

cp /usr/bin/ping /var/lib/machines/nsdc/usr/bin/
systemd-run -M nsdc -t /bin/bash
ping nethserver
ping client
rm /usr/bin/ping
exit

Here you can find some useful commands regarding NSDC and much more:

https://wiki.nethserver.org/doku.php?id=howto:useful_commands#samba4

Please follow these steps once again, try to reset the network adapters (local and virtual ones). Maybe reinstalling Virtualbox helps.

1 Like

it is fixed now only one change in the virtualbox setting Thank you for you Support

1 Like