Nethserver-sogo, needs test

testing

(Stéphane de Labrusse) #1

Hi I need returns on this version of sogo, I must know if you don’t have regression before to release

yum install http://mirror.de-labrusse.fr/NethDev/nethserver-sogo/nethserver-sogo-1.6.14-1.ns7.sdl.noarch.rpm

  • it should fix the correct displayed name

https://community.nethserver.org/t/sogo-full-name-field-proposal/8345/2

In fact these are several improvements for the sysadmin

    in the imap setting of sogo the full name is now fully written to didier de labrusse instead of only didier
    in the upper top of sogo you can see didier de labrusse instead of only didier
    in the shared emailbox you can see didier de labrusse instead of only didier
  • it should fix the emailbox sharing in imap (allow another user to use by acl your email box)
    once installed, share the INBOX folder to another user, the other user could see and use your email box (move, delete, answer email; depending given acl )

correct acl could be manually see in (adapt for each user)

/var/lib/nethserver/vmail/tata\@nethservertest.org//Maildir/dovecot-acl

you will see something like this (the full user@domain.com must appear)

user=tata@nethservertest.org akxeilprwts


(Jeroen Visser) #2

I will snapshot and try this on my production system tomorrow after hours … and on test before that :stuck_out_tongue:


(Jeroen Visser) #3

So, after applying the patch, results are mixed.

Things one should know reading the rest of this:

I create users like lms048@domain.com and lmst01@domain.com etc.
They get an email alias like j.m.visser@domain.com and t.account@domain.com

AD properties are populated to reflect the alias as the primary email and things like Fisrt name, last name, etc. are filled correctly.
Email clients are configured on the alias, using username lmst01 to acces the mailbox t.account@domain.com

In all clients, the @domain.com part is dropped from the username while logging on or setting credentials.

First annoyance is to be expected in my setup: (Sending mail)

Mailheader when sending mail from SOGo is correct.

EAX works as expected, including the mail header being wrong compared to how the return address is set in SOGo:

X-Spam-Status: No, score=-100.0, required= 4.0
X-MS-Exchange-Organization-PCL: 0
X-MS-Exchange-Organization-SCL: 0
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) * on
	otherserver.otherdomain.net * at Fri, 24 Nov 2017 07:47:37 +0100
X-Spam-Status: No, score=-100.0, hits=-100.0, required= 8, autolearn=disabled,
	 shortcircuit=USER_IN_WHITELIST (ham)
X-Spam-Report: * -0.0 SHORTCIRCUIT No description available.
	* -100 USER_IN_WHITELIST From: address is in the user's white-list
X-Process: ESTProcessDone
Received: from myserver.domain.com (172.16.1.12) by
 remote.someotherdomain.net (192.168.50.2) with Microsoft SMTP Server id
 8.3.485.1; Fri, 24 Nov 2017 08:33:49 +0100
Received: from myserver.domain.com (localhost [127.0.0.1])	by
 myserver.domain.com (Postfix) with ESMTP id 3B96B180336F5	for
 <jeroenvisser@someotherdomain.net>; Fri, 24 Nov 2017 08:33:49 +0100 (CET)
Received: from localhost (localhost [127.0.0.1])	by myserver.domain.com
 (Postfix) with ESMTP	for <jeroenvisser@someotherdomain.net>; Fri, 24 Nov 2017
 08:33:49 +0100 (CET)
From: Jeroen Visser <j.m.visser@domain.com>
To: <jeroenvisser@someotherdomain.net>
Subject: EAXtest
Date: Fri, 24 Nov 2017 08:33:57 +0100
Message-ID: <000201d364f6$96c12890$c44379b0$@domain.com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_0003_01D364FE.F885DEB0"
X-Mailer: Microsoft Outlook 16.0
Thread-Index: AdNk9pUQ8kYxJdosSoizqRE9JXLT+A==
Content-Language: nl
>>>>>  Return-Path: lms048@domain.com <<<<<<
X-Antivirus: avast! (VPS 171123-2, 23-11-2017), Inbound message
X-Antivirus-Status: Clean

IMAP works as expected, correct headers for my use-case and correctly displayed for common use-case, but not for mine :stuck_out_tongue:

But, and that is what this was about;

Note that for some reason, the first picture in this post has me looking up a user and it displays the accountname (my situation is weird, granted)

But I would expect that to be consistent … note this last pic displaying the users who have rights on this mailbox. This is mailbox j.m.visser@domain.com user lms048@domain.com
When looking for the Test Account user, it displays … the alias … as I would like … ehr ??

Rights are not correctly set in my scenario:

Manually setting rights to lmst01@domain.com works, as expected.

Strange behaviours:

  1. EAX return address in the email header is wrong
  2. Looking for user in SOGo when SENDING mail yields primary email addres (username in my case)
  3. Looking for user in SOGo when SETTING ACL’s yields alias email which has been set throughout SOGo settings like below:


(Jeroen Visser) #4

So, I will actually revert to my previous situation, as it had less confusion :stuck_out_tongue:
(I can test from both starting points if you like, made another snapshot)


(Stéphane de Labrusse) #5

You have a specific setting…I would love to hear others :slight_smile:


(Jeroen Visser) #6

While I agree that my setting would cause issues with displaying user-shared mailboxes in imap and displaying the name ‘wrong’ on SOGo, it shouldn’t yield the result I get while searching for the user during adding rights, wouldn’t you agree?


(Stéphane de Labrusse) #7

does it is not a cache problem ?


(Jeroen Visser) #8

Doesnt look like it. Same effect with a new user, after entering the AD property mail:

As you can see, not filling out the other properties leaves me with the username in front atm.
As soon as I set the fullname property:


(Stéphane de Labrusse) #9

I need time to migrate my email server to NS, after that I could start to do my tests in the real world


(Joel Clendineng) #10

I use sogo, dont like webtop…ill test. I have a sogo running in production, works well.


(Joel Clendineng) #11

Sogo works fine, this build wiped out my filters for mail, but that is understandable. So far no issues on my end.


(Markus Neuberger) #12

I tried it on a fresh install with openldap account provider. Full name is shown correctly now but newly created mailbox acls still write just username instead of username@domain.local to dovecot-acl file, so no access from allowed user:

/var/lib/nethserver/vmail/testuser@domain.local//Maildir/dovecot-acl:

but should be

If you change it and refresh sogo in browser markus can see testusers mailbox.


(Stéphane de Labrusse) #13

indeed, I did not patch the openldap server, thank to bring it up


(Stéphane de Labrusse) #14

please can you try

yum install http://mirror.de-labrusse.fr/NethDev/nethserver-sogo/nethserver-sogo-1.6.14-1.ns7.sdl.noarch.rpm

now the imap acl is set to username@domain.com


(Stéphane de Labrusse) #15

With Samba4AD

All seems good

however thunderbird displays the shared imap account by its email name, sogo use the full name, fun


(Jeroen Visser) #16

You can make it more fun by now setting the mail addresses in the sogo user configuration to an alias, as you would when you want the outside to use for instance the support mail to answer.

Not sure if even more fun arises when the mail property is set, I think not.


(Stéphane de Labrusse) #17

Sorry I don’t understand, you spoke to change the email address ‘from’ with the imap setting of sogo ?


(Jeroen Visser) #18

In sogo, you can set some settings by going to your mail settings, going to the imap settings tab of the sogo user settings for email, and editing that.

You can then set two mail addresses. I can not provide the screenshot right now, but did so in the other topic we went back and forth on about this issue.

(Screenshot will follow asap)


(Stéphane de Labrusse) #19

I know an issue in sogo when you change the ‘From email’ address, you cannot send email by thunderbird (or other clients) to attendees when you create an appointment.


(Jeroen Visser) #20

Would that then be a SOGo or an implementation limitation/bug?