Nethserver-glpi needs testers

GLPI is the Information Resource-Manager with an additional Administration- Interface. You can use it to build up a database with an inventory for your company (computer, software, printers…). It has enhanced functions to make the daily life for the administrators easier, like a job-tracking-system with mail-notification and methods to build a database with basic information about your network-topology.

The principal functionalities of the application are :

  1. the precise inventory of all the technical resources. All their characteristics will be stored in a database.

  2. management and the history of the maintenance actions and the bound procedures. This application is dynamic and is directly connected to the users who can post requests to the technicians. An interface thus authorizes the latter with if required preventing the service of maintenance and indexing a problem encountered with one of the technical resources to which they have access.

this application can work with ocsinventory-ng ->

Only yet for NS7

yum install

once installed you have some default users

Default logins / passwords are:

  • glpi/glpi for the administrator account
  • tech/tech for the technician account
  • normal/normal for the normal account
  • post-only/postonly for the postonly account

you have also some db

# config show glpi 
    Name=glpi        #change it for another web alias
    access=private #public/private
    status=enabled #enabled/disabled the web access

you must launch the event after a modification

signal-event nethserver-glpi-update

go to https://IP/glpi

As ever, please RTFM


Just installed, but 403 Forbidden: You don’t have permission to access /glpi on this server.
Newbie questions: I have installed on a machine which is in DMZ Zone. So, where is located the config file or, which are the CLI commands to change the access from private to public or better, to have access from both?
And ofcourse, can you made a jail for GLPI in F2B?


Another thing:
Every minute I have this:


config setprop glpi access public
signal-event nethserver-glpi-update

the config file is in /etc/httpd/conf.d/glpi.conf

1 Like

does mysql is running ?


systemctl status mysqld

I tried three installations and I never crashed the myqsld service…I don’t understand :’( what it occurs on your side

But but you are right that

[root@NS7DEV2 ~]# cat /etc/cron.d/glpi 
# GLPI core
# Run cron to execute task even when no user connected
* * * * * apache /usr/bin/php /usr/share/glpi/front/cron.php

we could redirect it to /dev/null

Thank you for your answers.
I’m driving home now but I’m sure that sql is working because on the same server I have also oSTicket and it works.
I will check again after about one hour and I will give you all the answers.

1 Like


I have these:

mysql is running, ok but something wrong in the mysql db creation

so first see if the db is created (look after the glpi db)


if it doesn’t exist, look in /var/log/messages and look after the ‘signal-event nethserver-glpi-update’ to see what is wrong.

if glpi db exists, we can try to recreate it

drop database glpi;


signal-event nethserver-glpi-update

In all cases watch what it occurs in /var/log/messages

in a terminal
tailf /var/log/messages

Something wrong with the access of the user root@localhost.

does it is a VM that you have played a bit ???

You have an Issue on your server…if you do


you should log to the mysql server, please test

I have already tried:

fun…did you try to change the mysql root password ?

Isn’t VM.
I think I did something when I have installed osTicket.
I will try to reset the root password …

the root password is

cat /var/lib/nethserver/secrets/mysql

should be also

[root@NS7DEV2 ~]# cat /root/.my.cnf

1 Like

I’m sure that I never changed this password!

It is not my fault…till I’m guilty :stuck_out_tongue:

1 Like

I did the following when I have installed osTicket and I changed the root password for sql but isn’t the password that I found now!

Is this the correct way, isn’t?

Reset MariaDB (MySQL) root password:

a. # systemctl stop mysqld
b. # mysqld_safe --skip-grant-tables &
c. # mysql -u root
d. > use mysql;
e. > update user SET PASSWORD=PASSWORD(“your_new_password”) WHERE USER=‘root’;
f. > flush privileges;
g. > exit
h. # reboot
(should be “systemctl start mysqld” but after a few seconds, the “mysqld (MySQL database)” service goes to “Stopped”; the reboot was the only way that I knew, to move forward).

Secure MariaDB (MySQL) installation:

a. # mysql_secure_installation

Change the root password? [Y/n] n
Remove anonymous users? [Y/n] y
Disallow root login remotely? [Y/n] y
Remove test database and access to it? [Y/n] y
Reload privilege tables now? [Y/n] y

well if you changed the root mysql password, you surely did a mess…

this is what you need to do for creating a mysql db…it is easy

better to ask to others how to reset the password @giacomo @davidep

1 Like

Copy your new password inside /var/lib/nethserver/secretes/mysql then execute:


Pray that everything will be automatically fixed :smiley: