Nethserver DHCP configuration using WDS PXE


(Alessio Orizio) #1

Hi all,

i’m new and i want congratulate with DEV people for the hard work for the last stable release !!!
I’m an IT admin and i started to use Nethserver like a transparent proxy with MAC binding firewall rule, so my goal is reached.
Now i ask you : how is the configuration for the DHCP to redirect to an external WDS PXE Server?

I use Windows SCCM ( WDS PXE ) to deploy on the pcs and i want to use it more.

I’ve found you documentation but if i didn’t seen bad the documentation explains only the situation of linux deploy.

The Apple Netboot work correctly without any Nethserver DHCP particular config and i can deploy my MACs on network.
I’ve a problem only with Windows PXE, but for me it’s 80% of work.

I ask you an help…
Thank you


DHCP-Option for FOG Server (https://fogproject.org)?
(Artem Fedai) #2

Hi @acsel10
Welcome to our Great community !

You could try to modify /etc/dnsamsq.conf in option 66 and paste your exteral PXE server.
If not try to use this manual
http://www.richud.com/wiki/Network_iPXE_dnsmasq_Examples_PXE_BOOT


(Filippo Carletti) #3

I use this custom template:

# cat /etc/e-smith/templates-custom/etc/dnsmasq.conf/81bootp 
# filippo - enable bootp on nethservice
dhcp-boot=net:eth0,pxelinux.0,nethservice.nethesis.it,192.168.5.252

(Alessio Fattorini) #4

Ehilá namesake!
The @dev_team would be happy to read your words. What are your feelings with NethServer? Are you using it at your company or for test only?


(Alessio Orizio) #5

Hi all,

and thanks for replyes.

@ alefattorini
i’m feeling good with Nethserver.
I’m using Nethserver like a gateway with web filtering in my work environment, an Educational environment; i started to use it after a test period obviously.
I think that it is a good complete solution for a lan networking and it has good growth prospects.

@Nas
i’ve tried to modify /etc/dnsmaq.conf in option 66 with a template-custom method. But no way. My Windows PXE server doesn’t recieve any request. The client takes an IP but doesn’t contact my PXE server.
For the guide of iPXE i red and thanks, but i hope to use simply the Nethserver dhcp to redirect clients to my PXE server.

@filippo_carletti
i’ve tried with 81bootp template-custom but doesn’t work anymore. Maybe i’ve insterted wrong value in a string, so i ask you if i did a mistake, this is the string in a template script:

dhcp-boot=net:“nic that contacts external PXE server”, “file on the external pxe server to execute(wdsnbp.com, in my case)”,“FQDN of external PXE server”,“IP of my extyernal PXE server”

it’s right ?
The external PXE is in the same subnet of the clients and the nic that offers DHCP service.

I noticed a thing in a dnsmasq.conf file, there is these two line:

  • dhcp-option=eth2,66,“IP of PXE server” # TFTP

  • dhcp-option=66,“IP of the nic of Nethserver on the same subnet of PXE”

I think that are in conflict, but if the first line can be addedd modifying by the web interface adding the value to TFTP option form, the second line i don’t know from what configuration has taken.

I hope that everything can be clear in my explication.
Thanks all for the support, have a good day !


(Filippo Carletti) #6

If you use the custom template, do not use the tftp field in the web ui.


(Alessio Orizio) #7

Ok. i’ve cleaned the field of web ui.

I get this PXE Error again:

PXE-T04: Access violation.
PXE-E36: Error received from TFTP server
PXE-M0F: Exiting Intel PXE ROM.

Can i specify the entire path of the file on the PXE server in the bootp line ?
Something like:

\SMSboot\x64\wdsnb.com

Can be usefull ???

Thanks


(Filippo Carletti) #8

I googled a bit, but I couldn’t find a solution. I’d try both a full path with forward and back slashes (/ and ).


(Bogdan Costin) #9

Hi it could be possible that you might need to use double slashes. Like:

\\SMSboot\\x64\\wdsnb.com


(Alessio Orizio) #10

Hi all,

i’ve tried the solution that you suggests but…no way…i received the same response:

PXE-T04: Access violation.
PXE-E36: Error received from TFTP server
PXE-M0F: Exiting Intel PXE ROM.

This is the line for the bootp option in my dnsmasq.conf:

dhcp-boot=net:eth2,//reminst//SMSBoot//x64//wdsnbp.com," FQDN of my pxe server* ",172.17.0.10

or i tried

dhcp-boot=net:eth2,\reminst\SMSBoot\x64\wdsnbp.com," FQDN of my pxe server* ",172.17.0.10

I use that path because it is the real path, WDS PXE put his binaries in that shared folder REMINST.

I don’t know what’s wrong, it seems to be everything right in the DHCP configuration.

Thank for replyes to all !!!

It’s strange that i’m the only one that have problem or work with Windows PXE Deployement :smile:


(Bogdan Costin) #11

Hi, As far as I know the FQDN will not work because in PXE you do not make dns queries.
You can try with the simple hostname or you can try to use the IP of the server instead of the hostname.


(Alessio Orizio) #12

Finally it works !!!

My goal was into change that i have done:

  • i’ve modify the script in the /etc/e-smith/templates/etc/dnsmasq.conf/80tftp

    the line $OUT.=“dhcp-option=66,”$LocalIP""
    with $OUT.=“dhcp-option=66,“the ip of my PXE external server””

I don’t know why but without this change in the dnsmasq.conf the configuration was:
dhcp-option=66,"IP of the nic of Nethserver on the same subnet of PXE"
and it was wrong.

  • then i’ve modified, following your tips, the script in template-custom folder. And finally the line in the script became:

    dhcp-boot=net:eth2,\SMSBoot\x64\wdsnbp.com,172.17.0.10,172.17.0.10

    • 172.17.0.10 is the IP of the external Windows PXE

And now i can deploy what i want…

Thank you all for the support, really !


(Alessio Fattorini) #13

Happy to see your achievements, you didn’t give up :muscle: