NethServer armhfp and aarch64 repositories


(Davide Principi) #1

It’s now possible to upload ARM packages to packages.nethserver.org! This is the usual upload-rpms command:

upload-rpms davidep@packages.nethserver.org:nscom/7.6.1810/arm-testing *.rpm

Allowed architectures are noarch, armv7hl, aarch64 and x86_64.

There is a new set of repositories whose names are prefixed with arm-: they are dedicated to the ARM team.

  • arm-base
  • arm-updates
  • arm-testing
  • arm-nethforge
  • arm-nethforge-testing

When an RPM is uploaded to arm- repositories

  • noarch and src RPMs are retained in arm-
  • armv7hl and aarch64 are copied (hardlinked) to the corresponding main repo, i.e. arm-testing goes to testing too, arm-updates to updates and so on…

In general, when a noarch is uploaded to any repository (for instance, “updates”) it is copied to all architectures:

  • x86_64
  • armhfp
  • aarch64

Random notes:

  • Repoclosure checks are disabled by now on ARM architectures
  • ARM repositories are still not sent to mirrors
  • The 7.5.1804 branch is going to be closed soon!

ARM development: next steps
(Mark Verlinde) #2

thank you @davidep for your hard work and pushing this further. :+1:

Still need some time to comprehend this, first thoughts are it can be problematic…
Again give me some time to digest.


(Davide Principi) #3

I still have to implement the “blacklist”. As repoclosure is now disabled, it’s not strictly required.


(Mark Verlinde) #4

I’ll work on it tomorrow, upload arm (initial only arm32 bit) dependencies and try to get a nethserver install up and running from the new repositories.

this should be possible. :grinning:


(Mark Verlinde) #5

Uploading packages fails…

$ upload-rpms markVnl@packages.nethserver.org:nscom/7.6.1810/arm-base *.rpm
sftp> put c-icap-0.5.2-1.ns7.armv7hl.rpm
Couldn't fsetstat: Permission denied

Despite sftp access is permitted:

$ sftp -i /home/mark/.ssh/neth_rsa markVnl@packages.nethserver.org
Connected to packages.nethserver.org.
sftp> ls nscom/7.6.1810/arm-base/
nscom/7.6.1810/arm-base/mark.Z5XyS0

(Note: i did “patch” upload-rpms to use the right key)

@davidep any ideas?


(Davide Principi) #6

That is not a fatal error: you can safely ignore it!

See also Couldn't fsetstat: Permission denied


(Mark Verlinde) #7

Yes, they did upload. thanx

EDIT @davidep
How is the arm-updates-groups.xml processed ? Can I upload one? its empty now…


(Davide Principi) #8

Nice catch, I must fix it! As we said in the past, we need a different comps file for ARM. I’d start by copying the one from x86_64, then we’ll add a new ARM-specific .xml file here: https://github.com/nethserver/comps (also for nethforge)


(Mark Verlinde) #9

Can you elaborate a bit more?
is the problem the missing comps file ? : I can manage this.
is the problem arm-updates-groups.xml is not “dispatched” to the ARM repositories?

To put a bit of pressure on it :rofl: IMHO the only reason we cant publish a alpha preview…


(Davide Principi) #10

Probably I can’t work on this today, I’m sorry :frowning:

If you can change the xml files consider that they should be applied once the arm-updates repo is built again


(Mark Verlinde) #11

After pushing a update to the arm-updates repo the arm-updates-groups.xml shows up in the repository’s. Unfortunaly the (x86_64) updates-groups.xml is also updated

Causing the change in groups to have no effect


(Davide Principi) #12

Thank you for reporting it! I’ll try to fix today, hopefully I just fixed it :tada:


(Davide Principi) #13

The upload spool dir has now some XML files

  • updates-groups.xml
  • nethforge-groups.xml
  • arm-updates-groups.xml
  • arm-nethforge-groups.xml

And some symlinks with arch suffix

  • updates-groups.aarch64.xml
  • updates-groups.armhfp.xml
  • updates-groups.x86_64.xml

Ignore the symlinks, that just point to the real files. What you have to upload is arm-updates-groups.xml. Filesystem permissions should protect against mistakes…


(Mark Verlinde) #14

Thank you, :+1:

It works on first sight :
the software-center shows only the for arm available packages :heart_eyes:


(Giacomo Sanchietti) #15

Wonderful work guys!