Nethserver-arm 7.7.1908 images for testing

I installed the RB image on a pi3. This is my first ARM device with NethServer :blush:

Great work @mark_nl! Building an image is complex and requires a lot of time: your effort is really valuable :trophy: :beer: :beers:

We are discussing some issues with the ARM image on GitHub: https://github.com/NethServer/arm-dev/issues/33

3 Likes

No personal preference: I like my systems clean small and agile (probably the arch linux heritage) . So i know how hard it is to remove stuff.
But note I can brew my own images to my personal likening, so its up to the community to decide… :innocent:

In the future I would love to have only the cockpit-bridge with nethserver-cockpit-lib running a NS arm-system. :thinking:

I think that is not enough. Cockpit still needs the application installed on the local system. In other words cockpit-ws is not needed when talking to cockpit-bridge through SSH port 22, but the other crap must be installed, sorry :innocent:

[root@vm1 ~]# cockpit-bridge --packages
base1                                                         /usr/share/cockpit/base1
domain                                                        /usr/share/cockpit/realmd
kdump                                                         /usr/share/cockpit/kdump
nethserver           Subscription, Applications, Software Cen /usr/share/cockpit/nethserver
nethserver-httpd                                              /usr/share/cockpit/nethserver-httpd
network                                                       /usr/share/cockpit/networkmanager
performance                                                   /usr/share/cockpit/tuned
selinux                                                       /usr/share/cockpit/selinux
shell                                                         /usr/share/cockpit/shell
sosreport                                                     /usr/share/cockpit/sosreport
storage                                                       /usr/share/cockpit/storaged
system                                                        /usr/share/cockpit/systemd
users                                                         /usr/share/cockpit/users
checksum = fcc91502d30754771cf3ab3b6461923b21c972ca993afe2229966dd7abb01f17
You have mail in /var/spool/mail/root
[root@vm1 ~]# 
1 Like

Yes noticed because i tried…

So votes are 1:2 on nethsever-cockpit which means RC2 will include cockpit.

I’d like to publish an RC2 because I am going to try to git rid of NetworkManager to fetch a dhcp on first boot. We did not need it on 7.6 but on 7.7 we do. It throws a message of the like dependency for networkmanager not found networkmanager not installed at negotiation DHCP and moves on without fetching a IP from dhcp. Note this is before multiuser-target so can be hard to fix .

1 Like

Tomorrow I’ll investigate how the systemd unit network.service starts DHCP client in place of NetworkManager in the x86_64 configuration.

2 Likes

There’s an RC1-draft release available for download and testing on GitHub releases. I guess you need a GitHub account and be member of the NethServer team to download it until we set it “published”.

https://github.com/NethServer/arm-dev/releases/download/rc1/Nethserver-7.7.1908-RC1-RaspberryPi-img-1572015631.raw.xz

This image installs the Cockpit Server Manager and fixes issue #33 for YUM repo metadata signatures.

I followed @mark_nl instructions to build a RPi3 image. Again, great work man! :trophy:

2 Likes

Very Nice :+1:

Going to test this weekend and try to get rid of NM,

Thanks for your input in this community effort, really appreciated :star_struck:

2 Likes

great! :raised_hands: but i can’t download it… :worried: any chance to to upload it somewhere else?

1 Like

Please try again with a new link

https://github.com/NethServer/arm-dev/releases/download/rc1/Nethserver-7.7.1908-RC1-RaspberryPi-img-1572015631.raw.xz

2 Likes

thanks, downloading… :clap::+1:

2 Likes

quick test, and all seems ok with yum repo metadata.
I’m not sure I understood correctly the problems with NetworkManager, but the rpi correctly get ip from my dhcp… i think i must re-read issue #33 :thinking::sweat_smile:
but the real, big problem are the hardware/cpu fileds in Dashboard :blush: :rofl:
so i played a bit merging old e new code and it look better now :innocent:
is it nethserver-cockpit/api/system-status/read the only file to change or i am missing something in the big (and unknown for me) cockpit world? :thinking:

rpi3_cockpit

1 Like

I think it is the only file you need to change.

2 Likes

Hello David

no test today :frowning: i am using the new ling but download speed is 20k so it neeed more than 4h

thank you, opened an issue: https://github.com/NethServer/arm-dev/issues/34

1 Like

Works like a charm, So we can close closed #33 :+1:

But getting rid of that virus like peace of sh…tinking NetworkManager is not trivial.
Something definitively changed in 7.7

EDIT:
opened https://github.com/NethServer/arm-dev/issues/35

1 Like

Strange had the opposite experience : it was very fast :star_struck:

Any idea how to install NS on the pretty new Odroid N2? I guess the performance would be quite good.

I got Nethserver installed on Odroid N2. At first I installed Centos 7 on a system having the boot files from Ubuntu which worked fine. Then I installed the Nethserver repo and Nethserver got installed which in the end destroyed the route to NS. The system boots and when I try to login with putty /ssh I get a “no route to host”. The new NS system has the same IP as Centos before, I checked that. Something was switched by the NS configuratiom at the end of the installaton process.
Any ideas? Any hints where to search?


Do i understand correctly the system has an IP Series after the NS install but you can not reach it using the hostname?
What if you try to reach it on the IP with putty?

No, in fact everything went well til to the end of the NS system configuration. Then the network ist destroyed and doesn’t come up anymore when the system reboots. The last message I saw on the putty screen regarded the creation of symbolic links. After that there is something like “OK. Completed.” which I could see in the install log but not over ssh.
Can anybody tell what happens there at the end of the system configuration and how I can avoid killing the network?