NethServer 7 RC2 crashes when I install / uninstall module or update system

NethServer Version: 7 rc2
Module: nethserver-roundcubemail

Hi all!

I have installed Nethserver 7 RC 2 with no problem, while I installed the modules I stumbled upon a system “crash”. Not a real crash. It is as if the NethServer does not complete the task of install / uninstall nethserver-roundcubemail.

This problem occurs in both cases and the task has not ended even after hours forcing me to reboot the system.

After the system restart, the module is not configured correctly and I can not access it at

Since yesterday evening, only now the uninstall task was unlocked and the ram and swaps which were saturated are empty.

Can anyone give me some guidance for correctly install the module or do I have reset the system and start over?

Thanks in advance,

Hi, can you provide the output of:

cat /etc/centos-release
rpm -qa *sssd* *roundcube*

Do you see any relevant error in /var/log/messages ?

There were some updates to do and I started them. Just finished updating place the result. Now I’m not allowed to var/log/messages. I tried to open the file but can charge without giving me a result.

BTW, NethServer 7 RC3 has been baked and it’s hot out of the oven. :slight_smile:

1 Like

In fact, I believe that the system is updating the RC3. However, when the update will end, I will try again to install the nethserver-roundcubemail module.

If the issue comes up again, I will post new info, otherwise I will say that I have solved the problem.

1 Like

Good. There are some additional steps when upgrading from RC2 to RC3: see the release notes


The upgrade task has the same problem, it is blocked for hours! :cry:

Similarly, as described in the previous post, the progress bar remains locked and the items are repeated in a loop.

Adjust service rsyslog


Everything is repeated, but the task does not advance. Stuck at 83%.

But in Dashboard it reads:

System Version: NethServer release 03/07/1611 (rc3)
Kernel Kersion: 4.4.22-1.el7.elrepo.x86_64

In your opinion, what can be causing this block? If there is a way to solve, give me some indication, I shall be grateful! :slight_smile:

Otherwise I have to reinstall and start over.

Is sssd service started?


Hi @pasing
As mentioned by @dnutan, after the upgrade you run from shell, the command:

signal-event nethserver-sssd-save

You did it?


Hi All,
after three days, now back to work on the problem!
By logging on to the system, via the web, this is the state that I see:

If I access the command-line system is that what I see:

According to you, what can I do? reboot the system?

Yes reboot should work. If you prefer try to get a shell and type

systemctl stop httpd-admin
systemctl start httpd-admin

I can not stop httpd-admin.
systemctl stop httpd-admin produces the following error:

Failed to stop httpd-admin.service: Activation of org.freedesktop.systemd1 timed out
See system logs and 'systemctl status httpd-admin.service' for details.
Failed to get load state of httpd-admin.service: Activation of org.freedesktop.systemd1 timed out

Idem for systemctl status httpd-admin.service:
Failed to get properties: Activation of org.freedesktop.systemd1 timed out

in var / log / messages is always the same message:
… [System] Failed to activate service’org.freedesktop.system1 '…

Journal: ptrack […] ERROR Traceback […]

I proceed with the system restarts

Even reboot it works.
Failed to start Activation of org.freedesktop.systemd1 time out
See system logs and ‘systemctl status’ for details.
Failed to open /dev/initctl: No such device or address
Failed to talk to init daemon.

The system was low memory and some processes were killed randomly. Crtl Alt Canc? Power reset?

I will brutally off the machine from the power button.
Ctrl Alt Del did not work.

I think you’re experiencing hardware problem:

  • your machine doesn’t have enough RAM + swap
  • IMHO you should check your RAM status

@davidep how can I check if the update has been successful?

Versione sistema
NethServer release 7.3.1611 (rc3)
Versione kernel

Modello CPU
2 x Intel® Xeon® CPU W3503 @ 2.40GHz

1730 / 5960 MB
Memoria libera
4230 MB

0 / 6016 MB
Swap libero
6016 MB

@giacomo believe that these resources are not enough?

I don’t believe it’s a ram shortage. I think you hit the nethserver-directory bug or similar during uninstall.

Follow rc3 release notes to fix the DPI module without Lt kernel

Not at all! :open_mouth:
But you surely have memory problems.

As first step, reboot the system with the new kernel and remove the kernel-lt.
Then try to list all memory hungry process (I’d check clamd as first).