NethServer 6.7 rc1 ready for testing

iso
testing

(Davide Principi) #1

NethServer 6.7 is coming!

Dear testing team (@vcc, @mabeleira, @medworthy, @dz00te, @fasttech, @GG_jr, @Adam) and anybody else,
the NethSever 6.7 rc1 ISO is ready for testing. It’s about 477MB and is available as Bittorrent download at

http://mirror.nethserver.org/nethserver/torrent/nethserver-6.7-rc1-x86_64.iso.torrent

* sha1sum
  1ab8b8938b369b3f634178291b2dbb30fe00ddba  nethserver-6.7-rc1-x86_64.iso

* md5sum
  8d822379e9838b4884b62dff723bd66b  nethserver-6.7-rc1-x86_64.iso

The ISO is built on CentOS 6.7 minimal ISO, and contains additional NethServer packages from 6.6 and 6.7 beta1 branch.

I installed it successfully on a VM, following the unattended install method. After reboot everything worked as expected, from First configuration Wizard to installation of additional modules from the Software Center.

Further tests should cover

Who wants to help? Any upgrade of existing 6.6 system is very appreciated :smile:


September Development Updates
Iptables vs shorewall
Community Digest 6 - October 2015
(Adam) #2

I’ll be upgrading two installs as soon as it’s done downloading.

Also seeding the torrent for a while.


(Davide Principi) #3

Thanks @Adam, torrent seeding is very appreciated :thumbsup:


(Adam) #4

Upgrade is only supported from rpm? Not from the ISO/CD?


(Davide Principi) #5

Yeah, those commands must be issued manually.

This is not a technical limitation but an upgrade policy. We can amend it. After 6.7 Final we could push the nethserver-release-6.7 package into 6.6 repositories to allow upgrading from the UI.


(Gabriel GHEORGHIU) #6

Hi Davide,

I will do in this way, on my home NetServer acting as UTM, from SSH.

Kind regards,
Gabriel

UPDATE:

Ready!
Log file (Davide, maybe you want this): http://1drv.ms/1OEzjeZ


(Adam) #7

Upgraded one of my NS VMs and saw some odd behavior:

Firewall objects, firewall rules, multi WAN, port forwarding, traffic shaping and snat 1:1 are all missing from the menu

This is what’s installed

So… upgrading removed firewall package?


(Gabriel GHEORGHIU) #8

Hi Adam,

You are right!

I observed this and I thought to start from scratch with 6.6 and then with upgrade again, to be sure that is not a mistake but now no longer the case.

And on Installed packages, Italian language appear as Installed.


(Alessio Fattorini) #9

Looks strange, tomorrow @davidep will take a look asap
About Italian is normal, now you can remove it, before 6.7 you can’t :wink: @giacomo am I right?


(Davide Principi) #10

I’m looking at

http://dev.nethserver.org/issues/3258#note-5

It is considered the expected behavior of upgrading the firewall package. The manual fix is provided by the test case 2, with command

yum update @nethserver-firewall-base

@giacomo, we’ll write down a release note about it!

Edit: only the UI is missing. The applied firewall configuration must be left untouched. Please @Adam and @GG_jr can you confirm that?


(Adam) #11

That resolved it!

Thanks! :smile:

Yes, it still appeared to be routing traffic. ipsec vpn even still worked!


(Gabriel GHEORGHIU) #12

You are right!


(Gabriel GHEORGHIU) #13

I did from Software center and now all are showing on left UI (although all worked: DHCP, …; there was no need to reconfigure).


(Davide Principi) #14

Could you explain how did you achieve the correct firewall UI upgrade from the Software Center page?


(Gabriel GHEORGHIU) #15

The module Basic firewall was in Software center -> Available.


(Jose "Martin" Abeleira. AKA Marto) #16

Downloading


(Gabriel GHEORGHIU) #17

Hi Davide,

In this upgrade I don’t see Password manager in the left UI.
If I remember well, when I tested the upgrade from 6.6 to 6.7 Beta1 also not appeared, but with unattended ISO installation (6.7 Beta1) it was.

Gabriel


(Davide Principi) #18

It is now bundled with nethserver-directory RPM. If you installed File server, Mail server or any other module requiring User and Groups, you must see the Password manager, too.

But if you’re looking at your firewall installation probably you don’t (and won’t) have it.

See also
http://dev.nethserver.org/issues/3260

Edit: BTW I can see “Password policies” into the @Adam’s screenshot above


(Gabriel GHEORGHIU) #19

Hi Davide,

Thank you. You are right!

Gabriel


(Gabriel GHEORGHIU) #20

Yes. That mean he had installed before upgrade at least one of those modules who need password to access.