Neth 7 Networking Problems with OVH Custom ip rules

NethServer Version: 7
Module: unknown

So… Here is what i have done so far I ran ip addr which gave me the interfaces and told me the proper interfaces name… I created /etc/sysconfig/network-scripts/ifcfg-ens19

Next I created: /etc/sysconfig/network-scripts/route-ens19

GatewayIP - ens19
NetworkIP - ens19
default GatewayIP

Next in /etc/resolv.conf

Ok so in a regular installation this information works however in a neth installation it doesn’t work… What am i missing?? What exactly are you all doing with the networks?

Before i wrote a shell script to force it to its route in Neth7 it doesn’t seem to work any thoughts??
Here is where are directions are for ovh style setup keep in mind our gateway addresses are way different than typical

Hi @lorentedford,

I do not use OVH but I found a thread about installing:

Some info on how NethServer handles networks:


Thanks this might be what i am looking for!

To give an example

my gateway ip is and my server ip is lol i know its funny networking stuff.

1 Like

Well i am not hiding it anymore i tried this…

db networks set ens19 ethernet role red ipaddr netmask ipaddr gateway onboot yes bootproto static

didn’t work

What happens if you try (or the one you got from your ISP) as subnetmask?

EDIT: Forget it, I mixed that with your ASPR question…

1 Like

Here is the instructions from my isp…

@filippo_carletti: The problem is here after several years, the solution will be here?

Hey what i did here worked but it was a pain in the rear every time i rebooted the system.

1 Like

@filippo_carletti, @giacomo: I do not find the solution after several weeks of patience.
Can you solve it?

Recall: @lorentedford has same problem too…

AFAIK it’s solved in How to make /etc/sysconfig/network/route-eth0 static - #8 by filippo_carletti

@filippo_carletti: No, it is not, there are several problems.

I have done several screenshots to show you the error…
It is not possible to add a feature (to force) which helps users?
We are a lot with problems and it will be same in NS8 too.

I have given you a part of the temporary solution but it is not in the code and it is not possible to change LAN (green) to WAN (red), and the Network IP / Gateway IP.


Hi @ElKorbo

AFAIK, this issue is ONLY with OVH, all other hosters I know of use normal IP rules…
So it’s an issue only for people setting up a server/gateway in OVH.

For no one else does this problem exist.
So I personally downvote the urgency…

My 2 cents

@filippo_carletti, @davidep, @Andy_Wismer: In more OVH (millions customers), I see same for DigitalOcean, Scaleway:




Can you add the feature directly in the main code?