MULTI-WAN link showing 'DOWN'

multiwan

(Vinit Makol) #1

First of all congratulations to all involved. Setting up the server thus far has been a true breeze, and everything(for the most part) has been working smoothly. I am new to the Linux world and must admit that there is a learning curve, but NEthserver has made things very easy.

The only thing I cannot get to work is the ‘MULTI-WAN’. I can see on the dashboard that the interface link is green and OK, but the same connection on the MULTI-WAN is showing ‘DOWN’.

There are two connections with weight 50 and 100.

Connection 1(UP) is static IP weight 50, and 10 Mbps down/2 Mbps up.
Connection 2(DOWN) is static IP weight 100, and 20mbps down/5 Mbps up.

The mode is set to ‘Balance’, and rest are all default values. Any ideas on what I could be doing wrong?


(Michael Träumner) #2

It’s not the same as your problem, but perhaps the solution can help you too:


(Prat) #3

Have played around with various combinations of DNS server settings (Google and ISP provided). Changing the DNS entries did not solve my issue, thus I’m posting details to this thread (after checking multiple other threads related to Multi WAN).

System version: NethServer release 7.5.1804 (rc)
Kernel release: 3.10.0-862.3.2.el7.x86_64

This system has been working for over a year, flawlessly. Last week, we added another NIC, because we got an additional DSL connection (low-bandwidth one). However, when both NIC are plugged in and configured, both show as DOWN in the Multi WAN section of the dashboard (both show OK in the Interfaces section and show Link status is up in the Network section).

Note that if either of them is plugged in independently, the system works fine. Also note that the DSL modems are properly configured and have no connectivity issues.

Original NIC (enp3s0) configuration:

  • IP: 192.168.1.2
  • Subnet: 255.255.255.0
  • Gateway: 192.168.1.1
  • Name: red1
  • Weight: 100

New NIC (enp4s0) configuration:

  • IP: 192.168.2.2
  • Subnet: 255.255.255.0
  • Gateway: 192.168.2.1
  • Name: red2
  • Weight: 10

If anyone could point out what I’ve done wrong, I’d be much obliged! :slight_smile:


(Michael Träumner) #4

I think your gateway configuration is wrong. Who is 192.168.1.1 and 192.168.2.1


(Prat) #5

Thanks for your response!

In reply to your question…
192.168.1.1 is the LAN IP of the old DSL modem.
192.168.2.1 is the LAN IP of the new DSL modem.


(Michael Träumner) #6

Did you check your DNS settings like mentioned in post 2?


(Prat) #7

Yes, I did.

As I said in my first post, I have played around with various combinations of DNS server settings (both Google as well as ISP provided) in the Nethserver DNS section.

If someone has a running configuration with two red NIC, pretty please drop a line with details on how they have set it up? :slight_smile:


(Michael Träumner) #8

@support_team Has somebody else an idea?


(Filippo Carletti) #9

I have installed a second wan yesterday evening, I had no problems at all, it works.
Having said that, I don’t know what could have gone wrong in your case.
Some commands useful for debugging:

# shorewall status -i | grep Interface
   Interface en2 is Enabled
   Interface en4 is Enabled

To force enabling a disabled interface:

shorewall enable en4


(Prat) #10

Sorry, was offline for the past few days.

Do let me know if I can run any other commands which will provide further information, which I can then share with you.

Meanwhile, if it’s okay with you, could you please share the IP configurations of both your red NIC? Since the configuration of both the DSL modems is in my control, I can try replicating your test setup.


(Prat) #11

@filippo_carletti I set the multi WAN mode to Active backup, and configured the NIC as follows:

enp3s0

enp3s0 - pci Realtek Semiconductor Co. Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

Link status is up
Speed 100 Mbit/s
Driver r8169
Mac address [redacted]

Role RED

IP: 192.168.1.2
Subnet: 255.255.255.0
Gateway: 192.168.1.1
Name: red40
Weight: 100

enp4s0

enp4s0 - pci Realtek Semiconductor Co. Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

Link status is up
Speed 100 Mbit/s
Driver r8169
Mac address [redacted]

Role RED

IP: 192.168.15.2
Subnet: 255.255.255.0
Gateway: 192.168.15.1
Name: red41
Weight: 100

Next, I checked this:

# shorewall status -i | grep Interface
Interface enp3s0 is Disabled
Interface enp4s0 is Disabled

Thus, ran the command you provided, to get both of them up. So, in the Dashboard section, the Multi WAN section showed both as UP.

However, still unable to get internet access. Tried ping from the server:

# ping google.com
ping: google.com: Name or service not known

Please note that this server has the ASUS H270M Plus motherboard with the problem where, on switching on the server, we need to run the “signal-event interface-update” command to get the network up. Please refer to this post where you and @giacomo have advised us, previously: Networking issues after installing AD

The weird thing is, we have to physically unplug any one of the two NIC and only then does the system work (after running the “signal-event interface-update” command). Simply releasing the role doesn’t work.

Please let me know if there’s any further data I can provide you, to help figure this out.


(Prat) #12

Have fixed the problem. @filippo_carletti, @giacomo please note that it seems that Nethserver is unable to handle static IP settings.

Following was the fix, for anyone else struggling with the issue:

  1. Release roles of both the red NIC
  2. Switch both modems to DHCP mode and perform DHCP IP reservation for both the red NIC
  3. Configure the red NIC in Network section, as required
  4. Reboot!

Note that switching over to DHCP has also fixed the issue where the network would remain down (on restart) and we had to run the “signal-event interface-update” command.

Thanks for everyone’s help! :slight_smile:


(Valeriy) #13

I have a Multi Wan configured. Red1 (static IP), Red2 (DHCP). When the Internet goes to red1, the system automatically switches to red2. But back switching does not happen. Only if you physically disconnect the cable from red2, then only red1 switches.

DNS for connection testing 8.8.8.8

How to solve this problem?
P.S. Also the status is not correctly displayed.
It shows red1 UP, but the Internet works through red2.
It shows red2 down but in fact the Internet works through red2.

This is visible if you select Diagnostics - External Public IP


(Valeriy) #14

red1 static ip.
red2 DHCP.
The problem occurs approximately every 2-3 days. The red1 connection is disconnected (but in the panel it is displayed as up), red2 is turned on (in the panel it is displayed as down).
If you connect the red1 cable to another computer, the Internet works without problems.
Switching from red2 to red1 does not happen. How to solve this problem?


(Michael Kicks) #15

AFAIK NethServer MultiWAN diagnose the connection status with ping to specific ip addreses wrote on WAN and MultiWAN configuration.
Also the time and the number of attempts and errors is configurable.

Therefore, i suggest you to change a bit the configuration and… do some tests.


(Valeriy) #16

MultiWan setup
Multi WAN
Link name
red1
Link weight
100

Link name
red2
Link weight
50


(Valeriy) #17

How to set automatic return from red2 to red1? Help is needed!


(Filippo Carletti) #18

Switch it’s automatic. If it’s not happening it may be caused by the router.
You could debug it with two tcpdump (one per red interface) looking for icmp packets.


(Valeriy) #19

Can you write in detail how to do this?


(Filippo Carletti) #20

tcpdump -nn -p -i <red_eth_name> icmp