Missing restore folder after "Restore files to new directory" completes with no errors - With work around and possible solution

Neth > Restore

I had to do a restore and found the restore folder was not created after the restore. “Restore files to new directory” option used and the restore completes with no errors.

  1. Tested theory and found Special Character (’) which was in the Folder name I was recovering does not recover at that folder level.
  2. Completed higher level (root shared) full folder recovery. OK
  3. From Linux I renamed folder and restored back to network share.

I would not know how we could stop Windows users from creating folder with (’) but maybe if there was a warning in the Neth > Restore (that Folder names with (’) will cause issues) and an option to nominated where to restore the root shared folder might be an answer?

Anyway I hope this helps the community…

2 Likes

Let’s try to reproduce the issue and find a fix.

What engine and destination did you use for the backup?

@giacomo The backup was the standard duplicity system with no modifications and the data stored via a cifs share on a NAS on the network.
My take on it might be that the file to be restored needs to be wrapped in double quotes, to make it a continuous string. I suspect the routine saw the single quote but could not find a closing one. I did try manually to request the full string by wrapping the file name in quotes but that did not work at the GUI level.
As time goes forward users seem to write paragraphs for file names!

1 Like

Suggest this reports are similar

1 Like

:smiley:

We didn’t hit any issue with duplicity and restore but we will try to reproduce by creating files with the ' char!