Migration to office 365

Good afternoon all, i have a customer that wants to migrate to office 365 (i have tried to explain how good nethserver issue but they arent budging) anyway i am trying to complete the migration and i have tried 993, 143 TLS, SSL etc, i seem to get connected fine but when the migration starts all the mailboxes fail and i see the following message at the office 365 end.

Data migrated: 0 B (0 bytes)

Migration rate:

Error: ImapNoPermissionPermanentFailure: Imap server reported an error during SELECT indicating that the current user is not permitted to carry out the requested operation: ā€˜Permission denied (0.001 + 0.000 secs).ā€™.

Any help would be greatly appreciated



By the error I take this is not using imapsync but a migration tool provided by Office 365 that tries to connect to NethServer IMAP server with wrong user credentials or with a user with insufficient permissions.

Same error as in these cases: Migration to MS 365 error IMAP / Dovecot and Migrating to office 365 error Dovecot

Do not know the solution but you can check nethserver mail logs (and the ones the migration tool might provide) to get more info about how the migration tool is trying to connect and why it was denied access when trying to SELECT an IMAP mailbox/folder.


Thats correct it is using the Office 365 tool to sync the email, its strange as the tool sets up the folders in the office 365 environment on the users mailboxes just doesnt pull the email through and ends up with this error.

not much is seen on the logs on nethserver, this issue seems to have had a resolution on the group but the user didnt make the resolution known.

i have checked and all mailboxes correctly login, it just doesnt seem to pull the email

Just as an extra point to this i have now used the full email address as the user account as another website said this could solve the issue, at present that hasnt fix the issue.

i have also increased the number of connections to the server to see if that resolve it, again not looking promising.

From one of the links posted above, for dovecot they put as example:

Have you tried the troubleshooting guide linked above or some of the available migration powershell commandlets (if any)?

Apart from the ā€œImapNoPermissionPermanentFailureā€ ā€œerror codeā€ that brings almost no result, there isnā€™t much info to provide help (other than what is reported about user without permission).

This link may have helped, any thoughts on the mailadmin user in nethserver, is there one by default or is it something that needs setting up

I guess it can also be done without a ā€œmailadminā€ account.
The so called mailadmin account could refer to this:

The root user can impersonate another user, gaining full rights to any mailbox contents and folder permissions. The Root can log in as another user option controls this empowerment, known also as master user in Dovecot 2.

When Root can log in as another user is enabled, the following credentials are accepted by the IMAP server:

  • user name with *root suffix appended
  • rootā€™s password

For instance, to access as john with root password secr3t, use the following credentials:

  • user name: john*root
  • password: secr3t


All i have sorted this issue with help from another member, the public folder and the public/junk folder need to be excluded and then it works, all mail has now been transfered