Logon scripts question

You should use \netbiosdomainname\administrator to logon to that share, and should then have access to it … you can find the logs here:


Not sure which one to look in tho :blush:

1 Like

how can I know my server name ?

First thing to know is that your NethServer is not the Samba AD server.
You installed your NethServer with some name, you can find that under Server Name in the server manager.
The server manager can be found at the IP of your server on port 980


Your Samba AD container, will get the same name, with ‘nsdc-’ prepended. So if you named your server ‘myserver’ your AD container will be ‘nsdc-myserver’.

That name will only resolve when you use the same DNS server tho, so perhaps that isnt ready yet as you are installing, and that would explain why you need IP’s.

1 Like

Well…I’ve the name using trial and error :slight_smile:
But the script doesn’t work.
Damnit, nothing works for me on first try

Without knowing ‘the script™’ we cant help there :wink:

the script is:

@echo create new a:
net use a:\\Network path\folder /persistent: yes

net use a: \\server\share /persistent: yes

Edit: persistent is useless here … as you put it in a logon script … it will run at each logon …
Edit 2: the :exit can go, and the @pause should as well.

1 Like

Be also careful with spaces, mask them with ":

net use z: "\\server\share name"

Don’t worry, once setup it just works stable.

1 Like

do I need to install a VM inside the Nethserver to run RSAT ?
I guess I need that to create the policy.

No, it is not necessary to install a VM.
You can install RSAT on any available windows system that is connected to the network.

…AND joined to the domain, AND using the Samba AD as DNS server, else it will still not work.

well… every connected automaticly because I installed the RSAT on already domain joined PC
I see everything : Users, pc’s and groups I made in Nethserver.
I just don’t see the user scripts option in the properties
I only see this:

It would seem that you are not using Active Directory Users and Computers for this task, as even without having advanced features on, there are a lot more options in my properties windows.

In order to see the unix attributes and/or edit them, you need advanced features in ADUC.

The correct way to get to the users is opening mmc.exe and adding the snap-in Microsfot Active Directory Users and Computers, and use that to edit the user properties.

DId it and it still the same

Did you open “Active Directory Users and Computers” with admin rights? Easiest way is to logon with NethServer “admin” or “administrator” User and just open it or open it as other user “DOMAIN\admin”(hold shift key when entering context menu):

Then just browse to “Users” and you should find the Users to edit:

If that does not work please try another client to check if it’s a client or server problem…

Which Windows version do you use?


I can see everything - users, pc’s and groups.
I’m using Windows 10 and I downloaded a client for 10 and I opeped it with admin rights.
The only thing missing in the whole process is the Logon Script in Profile tab like some feature is missing somewhere.
Also profile and remote and joined together for some reason.
See picture above from my answer.

Seems to be an M$ problem, if you have the possibility just try on another client.

Please check your version of RSAT and try to install actual one and do updates and don’t forget to reboot as M$ systems like it.


I am really sorry for you that this all happens on your first NS install…but it’s not your fault, it’s M$ (again)

This is why I don’t want to install any crappy MS features.
It’s always a mess with these guys.
Everything has to be complicated and slow with microsoft.

1 Like

There already are some threads, feature requests and plans about improving Windows file server functions in NethServer for not beeing dependant of RSAT. Just feel free to add your opinion…

I am sorry to say, but this is NOT a Microsoft issue NOR a NethServer issue. I have just repeated my test on a new domain with a new Win10 machine, and it just works as I have shown previously.

Which Windows 10 are you using ? As not all will work:

Remote Server Administration Tools for Windows 10 can be installed ONLY on computers that are running the full release of Windows 10 Professional, Windows 10 Enterprise, or Windows 10 Education.

Also: Remote Server Administration Tools for Windows 10 is available only in English (United States) for this release. If you are running Windows 10 in a language that is not English (United States), be sure that you have installed the English (United States) language pack before you install Remote Server Administration Tools. Move English (United States) to first.

And finally: Actually I found the solution elsewhere.

And because you can’t actually uninstall it properly you will need to re-image or perform a system restore perhaps.

I guess this is why some techs still never update ha ha

The Also and Finally parts are from mmarkus’ link, they might be key here. In short: install a new Win10, upgrade, install English, make sure you have the right version of RSAT, and try again :confused:

1 Like