Login credentials FreePBX admin area

Hi,

must be something obvious but…

When I go to the FreePBX admin area (applications -> FreePBX) I see below options:

When I click administration it asks for a login. What are the default credentials please?

TIA

IIRC you set it at install wizard (first connect)

To reset the admin:

https://www.freepbxhosting.com/blog/reset-freepbx-password/

1 Like

Thanks @mrmarkuz. I couldn’t remember the password set at install time, for it was many moons ago I installed it. Now I remembered! :slight_smile:

I forgot to do my usual ‘trick’ by adding a db property to the related service, asterisk in this case. (httpd-fpbx is hard to remember :wink: )

config setprop asterisk FreePBXPass “mysecretpassword”

where the value is between quotes for passwords or pass phrases may have odd characters or spaces that are not accepted by the db system. I usually add important data as a property to the related service. It will be totally ignored by the templating system, but handy for me or others.

This way I don’t have to remember the password, but simply do config show asterisk. Also a ‘config show > config.txt’ will get me a nice textfile :slight_smile:

Thanks!

1 Like

When I try:
fwconsole unlock t3jpc7aie2ci1ud9peoh9uk5k1

I get the output
PHP Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{’ or ‘' in /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php on line 90 Whoops\Exception\ErrorException: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '’ in file /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php on line 90
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php:90

I’m stuck out freepbx. My bad, i did not noted the admin password of freepbx.
Shame on me.

But… i get the id session.
And i found the way to forward command
fwconsole unlock <sessionid>
to rh-php56 through
scl enable rh-php56 -- fwconsole unlock <sessionid>
the answer is

Session save path is undefined. This can cause undefined unlocks. Please set a 'session.save_path' in your php.ini file. It should match the same path that is set for the web portion of PHP. We have defaulted to [/var/lib/php/session]
Unlocking: <sessionid> Failed, Invalid session

If I am not that dumb, I should have found the right directory, which IMVHO should be
/var/opt/rh/rh-php56/lib/php/session
but is empty as my brain
Using find -iname <sessionid> i can’t find anything on the filesystem.

Quite stuck…
output of find -iname session is

./var/lib/php/session
./var/opt/rh/rh-php56/lib/php/session
./var/www/html/freepbx/admin/modules/userman/vendor/illuminate/contracts/Session
./var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/http-foundation/Session
./var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/http-foundation/Tests/Session
./var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/security/Http/Session
./var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/security/Http/Tests/Session
./usr/src/freepbx/amp_conf/htdocs/admin/libraries/Composer/vendor/symfony/http-foundation/Session
./usr/src/freepbx/amp_conf/htdocs/admin/libraries/Composer/vendor/symfony/http-foundation/Tests/Session
./usr/src/freepbx/amp_conf/htdocs/admin/libraries/Composer/vendor/symfony/security/Http/Session
./usr/src/freepbx/amp_conf/htdocs/admin/libraries/Composer/vendor/symfony/security/Http/Tests/Session
./usr/src/freepbx/amp_conf/htdocs/admin/modules/userman/vendor/illuminate/contracts/Session
./opt/puppetlabs/puppet/lib/ruby/2.1.0/cgi/session
./opt/rh/rh-php56/register.content/var/opt/rh/rh-php56/lib/php/session
1 Like

It seems this doesn’t work (anymore). I found this bug so I set session.save_path = "/var/opt/rh/rh-php56/lib/php/session" in /etc/opt/rh/rh-php56/php.ini, it eliminates the path is undefined error but unlocking still doesn’t work.

There’s another way to set the password directly in the database (Source):

Following example sets the password of user pbxadmin to newpassword:

mysql -D asterisk -e "UPDATE ampusers SET password_sha1=SHA1('newpassword') WHERE username='pbxadmin'"

1 Like