Installing openfire 4.0.3 on the latest NS7

Has anyone suceed on installing openfire on NS7b2?
I´m stuck on starting the services,

I have already installed the dependencies (glibc.i686) and set the openfire as a service.
I have also set the firewall with all the desired ports.

Starting openfire (via systemctl): Job for openfire.service failed. See ‘systemctl status openfire.service’ and ‘journalctl -xn’ for details. [FAILED]

The reason:
systemd[1]: Failed to read PID from file /var/run/ Invalid argument


Never tried, but check this:

It seems you should install also zlib.i686 and libstdc++.i686

@tim has done some effort on 6.6 take a look at:

Openfire on NethServer

Tim, can you help us?

Thanks for repplying.
I had already installed these dependencies and I had the same error.
The error message is misleading, and with that, it took me a while to figure the problem.

I installed and I´m running now.
I should provide a how-to for who wants to run openfire as a chat server.

Best regards,


Glad to hear this.
It might be a great gift to the community! :gift: