Installing Odoo 8 on nethserver

I tried to install odoo 8 on Nethserver 6.7. I used following method to install odoo.

But the installing process is interrupting with the following error.
Import Error : No module named pbr.core.

how to install or add this module to continue installing of Odoo 8.


I guess you miss some python libraries…
Ask Google

you mean even if i install all the python apps recommended in the above link is not enough?

I read that it is quite tricky to install Odoo on CentOS 6.x because of multiple versions of php. Odoo needs php 2.7
Further Odoo uses PostgreSQL and not mysql or mariadb.

Here is a step-by-step that is closer to your configuration than the howto you used:


I guess you meant python

anyway, if python 2.7 is required (I don’t know, I’m just guessing), OP is in trouble, since you can’t upgrade python on centos (the first thing you’ll break is yum)

a solution could be software collections, but I don’t know if they are supported on NS (search here, hope you’ll find something usefull, if just the search function will ever work)

ofc I meant python… stupid mistake…
On other posts on the internet I see successfull installs of odoo 8 (and 9) on CentOS7… so maybe wait for the next major update of NS?

We’re using python 2.7 from SCL on (which is a 6.7) for letsencrypt.

Interesting… would you mind to share how did you setup it? Did you use the available rpm coming from suse buildsys?

Dear robb,

I followed the steps you recommended to me. everything worked fine this time (first time).
Odoo service started.
Postgresql-9.3 started.

but i cannot connect from other computer in the network. the computer says unable to connect.

my doubt is firewall or iptables. but in tutorial there was a step to add exception the port 8069.

if yes, how to configure firewall or iptables, OR how to finalize the issue?

How is your NS connected to the network? AFAIK the green interface has no blocked ports. Can you telnet to port 8069 from the computer to NS?

Check this out:
you have to create a new service for port 8069

Dear ale, I have followed the link you send to me. i type following command
config set fw_odoo service status enabled TCPPort 8069 access private
signal-event firewall-adjust

But on client firefox windows says following error,

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

You think the odoo is not configured properly?


Check following logs:

  • /var/log/messages
  • /var/log/httpd/error_log

Interesting… would you mind to share how did you setup it? Did you use the available rpm coming from suse buildsys?

Stefano, i installed again openerp using following link. The link is for odoo. But odoo not installing. Then i use this for openerp 7. It installed but when starting the service there is an error saying,
Line 24 error_strat-restart-stop daemon command not found.

But i checked it on centos 7. It works fine.

Btw, what is rpm of opensuse. ? I will try it. Is there a link with you to send me?

thank you ns_nirosh, but I was asking @filippo_carletti about letsencrypt on NS :smile:

Will this work on CentOS6.x/NS too? I understood that CentOS 7 is quite a different cup-of-tea than CentOS6.x

Robb, i checked with clearos also. The same error like NS. I think centos 6 is not compatible with tutorial.

I followed docs found on the net. I could look at bash history next week to copy actual commands.
Bear with me, please.