Icaro Dedalo Hotspot installation

I’ve a generally question to dedalo. What happens if a client asks for connection.
The gateway (dedalo server) tries to route to icaro portal web site, but does it always do this through red interface? If so, how can we change, because the icaro server is at the green interface.
We also tried to setup icaro server to the red network, but it doesn’t work also.
Of course the next problem is the DNS, only the nethserver where dedalo runs knows the icaro address, but I think the DNS server is only reachable from green LAN.
Hope somebody can clarify these things.

My Problem seems to be with dedalo, not icaro. Yesterday I connected my dedalo to an icaro installation from Markus. Markus gets the portal page with a client at his dedalo installation, I don’t get it running with my dedalo.

Hi @m.traeumner,
just to be sure… what is is network configuration on the dedalo side (NethServer)?
You need to have at least these 3 roles:

  • one red
  • one green
  • one hotspot

It is a Nethserver with a green interface for LAN, a red interface for WAN and a third interface setup by dedalo.

Hi @m.traeumner,
if I’m right you should have icaro (CentOS 8) and dedalo (NethServer) in the same network, in this case you should have the red of NethServer connected to CentOS.
Is that you configuration?

At the moment my icaro is at the green interface, but I tried at red interface too.
I also test it with an icaro server from @mrmarkuz, reachable through the internet.

Thanks for help

icaro at green interface is perfect (how many configured interfaces do you have on your icaro?one should be enough)

Is the red interface of nethserver connected to green interface of icaro?

At the moment the icaro interface is connected to nethservers green interface, but also tried to connect to nethservers red interface.
The Nethserver is for dedalo , vpn and for firewall, but also tried to disable things like ips. There are no special firewall rules on it.

Ok, Nethserver need to be connected to icaro via red interface, that is what usually happens when icaro is on a remote server.
So try to connected red if of nethserver and green of icaro.
If you don’t need a green on your nethserver you can leave it disconnected.

1 Like

Ok, I’ll try this again. But there is also another problem, because the server of @mrmarkuz is connected via internet (red interface).

Yes, make a new try, this seems to be quite difficult to detect and there are many variables involved, but if things won’t work I think you should ask for commercial support at this point.

1 Like

Thanks for your answer. I give it a try again, also with an other nethserver installation

1 Like

Hi guys, it seems, that we can’t get it running without a connection from outside to port 80 and 443.

  • I have a firewall with a green (LAN) and a red (WAN) interface.
  • Dedalo Server is connected with its red (WAN) interface to the firewall green (LAN) interface, dedalos green interface is a fake interface and dedalos 3rd interface is connected to the hotspot with dedalo hotspot role.
  • icaro (now on CentOS 7) is at the firewalls green interface
  • Dedalos first DNS is changed to the firewall address, which is an internal DNS and knows the domain of icaro.

Everything seems to work.

  • I can curl the icaro domain from a client at the green firewall network
  • a client at the hotspot network can solve the icaro domain with a nslookup

but I can’t reach the portal site.
The same configuration with a public known domain an a letsencrypt certificate works fine.

Special thanks to @davide_marini, @edoardo_spadoni for helping me and to @mrmarkuz, who spends much hours for rebuilding the same structure, testing and helping me to install.


I’ve rewritten the howto for icaro on CentOS 7 with a public domain name.
If somebody is interested have a look here:


2 posts were split to a new topic: No admin login at Icaro

3 posts were merged into an existing topic: No admin login at Icaro