HowTo: increase Zabbix ValueCacheSize

NethServer Version: 7.9
Module: Zabbix 5.0

If your nice zabbix 5.0 tells you that the ValueCache is insufficient for the configuration and you cannot optimize any of the settings (lots of thing could be done for that) you can still increase you ValueCacheSize.
As default config, value is not specified. Currently I don’t know which is the default cache size.

Therefore, after copying from the custom template and this post about other things, there’s my little howto…

Do you already have a custom template for Zabbix?

If you’re unsure, you can access to ssh/terminal on your installation, go to / and fire up find -iname zabbux_server.conf
If the output is exactly like this

./etc/e-smith/events/nethserver-zabbix-update/templates2expand/etc/zabbix/zabbix_server.conf
./etc/e-smith/templates/etc/zabbix/zabbix_server.conf
./etc/e-smith/templates-custom/etc/zabbix/zabbix_server.conf
./etc/zabbix/zabbix_server.conf

with the directory /etc/e-smith/templates-custom/etc/zabbix/zabbix_server.conf already existing, you already have a custom template.
So verify your custom-template which is, edit (maybe backup?) the existing file and add the line

ValueCacheSize=64M

then launch the usual

signal-event nethserver-zabbix-update

If you don’t have any existing template

Thanks for sharing Mr Markuz
Create custom template dir:

mkdir -p /etc/e-smith/templates-custom/etc/zabbix/zabbix_server.conf

Create /etc/e-smith/templates-custom/etc/zabbix/zabbix_server.conf/90custom with following content:

# 90custom - additional settings
ValueCacheSize=64M

(or any value you consider suitable)

Apply config:

signal-event nethserver-zabbix-update
And checkup your install. Maybe… the value need some more tweaking.

3 Likes