How to add/use Jitsi Meet in Webtop (version 5.11)

Hello @webtop_team, @lucag,

I’ve noticed in the release notes from Webtop version 5.11 that Jitsi meet has been added to Webtop!

I found this page:

https://www.sonicle.com/docs/webtop5/core.html?highlight=jitsi

But I’d like clarification of how Webtop uses Jitsi meet:

I see there are settings in the Administration of Webtop that have already been added to integrate Jitsi. How is the room name created for this Jitsi meeting through Webtop?

When I use Jitsi I also setup a password. Is there a way when setting up a Jisti Room in Webtop to create the password or will the password need to be added by my staff once they’ve entered the room?

The documentation is unclear how to use Jitsi in the meeting? I’ve created a calendar event in my Webtop but I don’t see any option to choose Jitsi. Where in Webtop am I able to choose Jitsi for my meeting invite?

Thank you.

there is also a rpm nethserver-conference to install IIRC https://github.com/NethServer/dev/issues/6463

1 Like

nethserver-conference should be automatically installed with last webtop update. Check in with rpm -q nethserver-conference.
If installed, go in Webtop Cockpit interface and set the Jitsi Meet url. I think you can use also default url if you don’t have a personal jitsi installation. (https://meet.jit.si/).

After that logout login in webtop and the integration with jitsi should be configured.

3 Likes

Hi Charles,
the new integration with Jitsi is included in the 5.11.3 release just released: https://github.com/NethServer/dev/issues/6463#issuecomment-821209041

Here you can find the documentation: https://nethserver.docs.nethesis.it/en/master/webtop5.html#jitsi-integration-and-support-for-links-to-third-party-video-calls

2 Likes

Thanks all for your input! @lucag, this was the link I was looking for! :slight_smile:

Question for you about using a calendar entry. I’ve enabled Jitsi as per the instructions and I can see the new link on my Webtop now:

Can I limit who sees this link in the Administration Panel? I have some Webtop Users who will use Jitsi meetings and others that should not. How can I limit who has access to setup a jitsi meet?

Looking at the admin properties I’ve added the meeting service for all users. Would I need to only add this service for the individual users (not by group - Users) to ensure Jitsi meeting can be used by certain users and not others? Or is there another way to specify which user can use Jitsi Meet from webtop?

When I created a calendar entry I selected the 'Add Meeting (Webtop Meet) button at the top of the new calendar page and I can see the Jitsi room setup for me on the public jitsi meet page. I added my Antendee’s and I saved/sent the invite. I confirmed that the attendee received the invitation and had the jitsi meet link added so they could join. But for the organizer of this calendar event, I can’t see the jitsi link to join? I opened the calendar event I scheduled and expected to see the link but could not find it. I pressed on the Meeting button at the top again but it provided me a new (different) room to join in Jitsi? When I’m the organizer I would expect to see the Jitsi meeting room that was setup for myself and my attendees to join. Where is this displayed?

Thank you.

Hi Charles,

sure you can limit the use to some users and not all.

To do this, you just need to add the authorization only to a few single users (or to a subgroup of users), and not to the users group.
In the documentation I have indicated how to add this permission for the users group just as an example :wink:

I did not understand this problem and I do not reply … :thinking:

The organizer who creates the event with invitation and creates a link for Jitsi when saving the event is placed on his calendar including the Jitsi room link in the “Location” field and the buttons to open the link automatically.

If you can provide more details with screenshots of what you find perhaps I understand better.

Bye.

2 Likes

Hello @lucag, I’ve tested the jitsi meet being added to a calendar so I could take some screenshots but upon retesting I now see the jitsi meet link in the meeting I setup in calendar so whatever I saw before is not occuring now. All good.

Jitsi meet is working great in Webtop! Really impressed that I can provide this added service for my staff to use.

Thanks @webtop_team for adding this to Webtop.

@support_team, is there any plans to add jitsi to Nethserver? That would make using jitsi locally in Webtop that much better.

Thanks!

1 Like

I’m glad you enjoyed this feature :grinning:

here you will find the thread where we talked about it including the howto:

Personally I recommend you to create a VM with Ubuntu on which to install Jitsi server :wink:

BR

3 Likes