Hotsync DC no user present

NethServer Version: 7.9.2009 (final)
Module: Hotsync


I tried Hotsync in a test environment. Server A is a Nethserver with AD.
On server B I created an AD with a different name from server A before starting to activate HotSync.
After having promoted server B, do I find everything correctly configured, including AD, but there are no users? What am I doing wrong?


You don’t have to create the AD on server B, which is the slave. You only have to configure the Hotsync part, and the package should do all the rest.
All the apps must be configured only on the master server; on the slave use only Hotsync interface.

1 Like

In a first test I had not created AD on the slave. When I promoted it, it was not reachable in the network. The bridge was present. I ran the commands in the doc but without effect.
I also recreated the bridge but as soon as I activate it the server is no longer reachable.
By installing an AD on the slave, the bridge is created and after the transition to the master the server is reachable.

Two servers are identical or different on NICs name?
We are talking of a firewall or only green Nic?

They are twin VMs so the hardware is the same. They are not configured as firewalls but mail/AD servers, only green Nic.


Ok… so during the hotsync-promote command, the server was able to communicate with the Internet or you receive this alert?

If no Internet connection is detected (e.g. you are restoring a firewall on a machine that was passing through crashed master for Internet connection), the scripts will purpose you some options:

> 1. Restore master network configuration (IMPORTANT: use this option only if two servers are identical - NIC number, names and positions must be identical)
> 2. Fix network configuration from Cockpit GUI (when restoring on different hardware)
> 3. Continue without internet: assign correct roles before proceed with this option. Some events could fails (not recommended)

During the hotsync-promote the server was able to communicate with the Internet and I did not receive any alters, but it completed the procedure automatically,


1 Like

So, you powered off the first server and then launch hotsync-promote on the second one?

1 Like



1 Like

Ok, if you can, I want to test it with you. It should helpful if you can retry with the behaviour, and then we can analyze togheter the log and the situation.

So, configure your master and then launch “hotsync” command

On the slave launch before “hotsync-slave” and then, after you powered off the master, launch “hotsync-promote”

I did exactly what you told me. Everything worked out. I made several checks and everything is perfectly synchronized. The difference is, I don’t know if that’s the reason for the failure, that I pressed the HotSync button immediately after configuring the sync service


Now to finish I have to type

signal-event post-restore-data

but I believe there will be no problems.

Thanks for the support

This button should launch “hotsync” command on master. So now it’s all ok?

I have finished all the steps and I confirm everything is working correctly. Just one thing, that on the final reboot the mail services went up more slowly. The webmail login was blocked. Soon after, without doing anything, everything worked smoothly.

thank you very much for your support