Helldesk corner: force google to accept imapsync

NethServer Version: 7.9
Module: Email

I have a quite abandoned google account i used to send some… messages from devices and receiving some notifications by network devices. Currently i have a separate mailbox for any domain managed, but the account still lives. And works (and it’s not part of the issue).

I can access from browser.
I can access from Thunderbird (Oauth 2.0).
ImapSync don’t seems to cooperate. I mean… It does, maybe is Mountain View who needs some bash time over the head.

The setup is the “usual” email + Webtop. The mailserver currently is not the mailserver for the domain but anyway… as imapsync should work as email client by google perspective.

I use password only. No 2FA (i don’t currently have a casualty smartphone to use for this account), “lesser secure applications access” enabled. Google keeps telling me “hey, i blocked your access” and me at the screen “bounty killer of my sockets, stop doing that”.

What I’m missing?

Is imapsync running behind the same public IP address as the browser and Thunderbird?
What is the exact error message on both sides (imapsync and the big G)?

The answer to the problem might be found at:

1 Like

In any case… thanks.

Not currently. Maybe I’ll try again when I’ll be onsite (but anyway… Google should tell me “i blocked, you want to access?” and i should be able to tell him “yeah, go for it”. I mean… hosted servers?)

Big G sayed “i blocked the access”. Which could be fine. But neither into imapsync or email logs i can find more details.
Also, I am configuring the first use of imapsync/connector, and the interface it only tells… “X”. Red.

Anyway… I’ll take my time on logs again.

Here it’s working with an app password from https://myaccount.google.com/apppasswords

My settings:

1 Like

App Password = 2FA.
Thanks for the experience but…

isn’t it that google has activated 2FA on the sly?
It’s doing it these days on a bunch of accounts (including one of mine), but it sends warning emails…



I retried without 2FA and it worked.

  • Removed app password
  • Deactivated 2FA and login via smartphone here
  • Enabled insecure apps here
  • Enabled IMAP in gmail
  • Used these settings in imapsync
1 Like

Did not used 2FA in first place and “checked all boxes” for

  • Insecure Apps (AKA no Oauth2)
  • Imap Enabled
  • Same config on ImapSync

I’ll take a round later for Imap access from Thunderbird AND Imapsync from the same ip.

This is what i did this time (succeeding)

From the same public ip Address:

  • accessed to Google Account on a browser.
  • configured Thunderbird via IMAP with “normal password” (no Oauth2)
  • configured Imapsync

And… it worked.

Don’t consider all these steps mandatory, they worked in my occurrence. Moreover, this could be a… successful experience.