GLPI Web root permission

GLPI 10.0.7 (/glpi => /usr/share/glpi)
Installation mode: TARBALL
Current language:it_IT

Hello everyone, I have updated the version of glpi, but it reports this error that I can’t fix.
I am also attaching two other items that deserve attention.

Hi @france, same here… Take a look: GLPI upgrade error

Hi and thank you, I had already upgraded ( from past experience) via console. But there is always the error of the web root permission and the session cookies, which I would not like to have misunderstood, still has to be solved. Or am I wrong?

I use GLPI 10.0.7 without a virtual host .

use a virtualhost to shut off this warning or live with it, see documentation

Ok thanks @stephdl , but is it just a warning or do I risk what I read?
I also ask you if I want to install or rather migrate / move glpi to virtualhost what should I do? Thank you .

read the documentation glpi-latest [NethServer Wiki] set a DomainName

Hello , I set up a virtual host that is resolved by the internal dns , but I have the same error as @fausp . Sorry for the question, but should all the glpi be moved under the virutalhost?

Why do you still use /glpi ?

Sorry it will be the translation but I don’t quite understand the question you asked me.

Tried it a minute ago and it works now for me…

[root@glpi ~]# config setprop glpi DomainName
[root@glpi ~]# signal-event nethserver-glpi-10-latest-update

You have to use the URL without /glpi on the end.

Thank you @stephdl!

1 Like

Yes, I also proceeded with this, but nothing to do.

Sorry but I understand now. Only domain name , but it shows up at the nethserver home page despite having tried with different aliases .

Because your domain name it is not resolved locally and it goes to your router ?

On your remote client that you use with your browser

Can you ping the virtualhost RELEVANT of DomainName

What is the output does it direct to the IP of the server running GLPI

Sorry if I’m only answering now. Name resolution happens with pi-hole re redirects all queries to the pfsense , which in turn sorts the domains of relevance to the local servers.

[root@golub ~]# config setprop glpi DomainName merzilio.mylan.local
[root@golub ~]# signal-event nethserver-glpi-10-latest-update
[root@golub ~]# config show glpi
[root@golub ~]#

[root@golub ~]# nslookup merzilio.mylan.local

Name: merzilio.mylan.local

[root@golub ~]#

Well I am lost like your are lost

Why you created a virtualhost on your ns7 where did you read it is a requirement ?

Why do you test that your domain name is resolved on ns7 it must be resolved outside of your nethserver 7 if you want other clients could connect

I made a lot of confusion, you’re right I only changed the domain name and now it works, but only on a server. The other server currently responds only with the default page of nethserver , while the one in test at the address of the domain name alone , responds with GLPI , without subsequently giving error . What can I do for the server in production? I ran the same parameters, but it looks like the nethserver home page was written before.

Do I have to check the dns?

Yes of course you need to set a dns somewhere for your clients

1 Like

Hi, I wanted to ask you a question about glpi and virtualhost.

On my server , named neth7.internal2.lan , I have always configured an alias .ddns es . . my pfsense has a dnat at port 443 wan > 443 lan towards the internal alias neth7.ddns > . It has been working great for several years with letsencrypt . Since it would not be appropriate with glpi to change the domain name with the already existing alias ( ) , I could alternatively create a new alias from the name e.g. . Having done this, how would I manage another let’encrypt certificate on the new glpi virtualhost? I state that I have the possibility to add a last hostname to ddns.

I was asking if it would be possible in the cockpit on the certificate menu, the request to create a new certificate with the new name of the glpi virtualhost, without clearly conflicting with the existing one. The requests would both always pass on the same port 443 from the wan to the lan always on the same server, but with an alias and a vistualhost. Do you think it’s possible?

Glpi uses the default certificate of ns7 whatever it is LE or self certificated.

So it should have no issue if you set the default certificate of the machine running GLPi to LE