GLPI - FusionInventory Plugin: X columns are not compatible with timezones usage

Hello everyone, after updating the fusioninventory plugin to the latest version I only encountered one problem :slight_smile:

Hello @france
Please translate your post in English. This is an English only forum since we are a global community. I hope you understand our (many) non-italian members don’t understand a bit of what you ask and, more importantly, can’t help you.

1 Like

Sorry, I didn’t pay attention …

Can you provide a bit more details? Anything in the logs?
Did you try to revert to the older version again?
Maybe @webtop_team can give some pointers?
my bad, for some reason I thought it was about webtop and not GLPI… reading is hard when you have a lot on you mind…

You can get some clues from this:

1 Like

It’s a bug (well sort of) it’s because it can’t access the TMZ data in MySQL/MariaDB or timezone isn’t configured in the db I’m currently looking for a solution and while I have a few they don’t fully work as it reports the tz data is corrupt or incorrect so I think it needs to be regenerated I’ll post my notes when Im back in front of my laptop

Hi Robb, I don’t understand the link with webtop and fusioninventory … I deleted the server snapshot as this error alone on the principle screen. Last time @stephdl intervened who solved the problem. However, unfortunately, I can now only play current logs to the existing configuration!

Hi Shane, so I understand that you also encountered the same problem. Your feedback would be very welcome.

However, I would like to point out that the problem is only related to fusioninventory after upgrading to version 9.5. +4.

We need the help of @stephdl … :sweat_smile:

try to explain the issue, a bit lost

That’s correct I know some of the issue is due to some of the tables missing in the new database

Hi Stephane, then I updated the “Fusion inventory” plugins to version 9.5+4 on glpi. The update went well, but only (at the moment) on the main mask of the dashboard is the timezone error. As previously written by @Shane_Treweek, it seems that the problem also occurred to him.

As you can see from the pictures, only the dashboard …

We used a script to populate the timezone in mysql, did you recall it ?


I remember you created a script for the timezone, we should watch the chat

I found this:

Yes it is


source /opt/rh/rh-mariadb105/enable 
mysql --socket=/run/rh-mariadb105-mariadb/glpi-mysql.sock -e "GRANT SELECT ON mysql.time_zone_name TO 'glpi'@'%';"
mysql --socket=/run/rh-mariadb105-mariadb/glpi-mysql.sock -e "FLUSH PRIVILEGES"
su - apache -s /bin/bash -c "/opt/rh/rh-php73/root/bin/php /usr/share/glpi/bin/console glpi:maintenance:enable"
mysql_tzinfo_to_sql /usr/share/zoneinfo | mysql --socket=/run/rh-mariadb105-mariadb/glpi-mysql.sock mysql
su - apache -s /bin/bash -c "/opt/rh/rh-php73/root/bin/php /usr/share/glpi/bin/console glpi:migration:timestamps --no-interaction"
su - apache -s /bin/bash -c "/opt/rh/rh-php73/root/bin/php /usr/share/glpi/bin/console glpi:maintenance:disable" (END)

I still have this script on the root folder


Issue fixed or not ?

Check also /var/log/messages after the script

So I try now, launch a snapshot and check the logs