FORM_ENC_MULTIPART error on first time config wizard

Hi all,

New user here.

I’ve tested nethserver v7 to see if it could do what I wanted. To install nethserver I used the path to install nethserver on a minimal install CentOS (usb stick with nethserver-iso crashed during install, usb stick with CentOS worked fine).
After some time testing I decided that nethserver was what I was looking for :slight_smile: , so I cleaned the harddisk and started a fresh installation.
After the installation I went to the management console. That should start the first config wizard, but I got an error: Undefined class constant ‘FORM_ENC_MULTIPART’

In the log I see:
httpd: [1] Undefined class constant ‘FORM_ENC_MULTIPART’ - File /usr/share/nethesis/NethServer/Template/FirstConfigWiz/Restore.php, line 4

The menu item “Server certificate” and “Backup (Configuration)” have the same error:
httpd: [1] Undefined class constant ‘FORM_ENC_MULTIPART’ - File /usr/share/nethesis/NethServer/Template/Pki/Upload.php, line 3
httpd: [1] Undefined class constant ‘FORM_ENC_MULTIPART’ - File /usr/share/nethesis/NethServer/Template/BackupConfig/Upload.php, line 4

Tried reinstalling again, but the error is persistent.
Anyone with a solution?


1 Like

Thanks. Bug already opened:

Thanks. Will wait for a bugfix then before I try a fresh install.

Sorry for the inconvenience, and thank you for your understanding!
The update will be synched to all mirrors in few hours :slight_smile: