First Pre Release Of Vaultwarden

Announcing First Pre Release of Vault Warden

Github Repo:


 add-module 1

Thanks for creating another nice app for NS8.

The NS8 mail notification was disabled so vaultwarden-app didn’t start.
2024-05-28T17:23:13+02:00 [1:vaultwarden1:vaultwarden-app] Both SMTP_HOST and SMTP_FROM need to be set for email support without USE_SENDMAIL

I needed to set SMTP_FROM and SMTP_HOST manually to make the app start.

After enabling the NS8 mail notification (using my mail instance) SMTP_ENCRYPTION in smarthost.env is set to “none” which doesn’t work with


from ../systemd/user/vaultwarden-app.service because “none” is not an option:

2024-05-28T17:47:39+02:00 [1:vaultwarden1:vaultwarden-app] SMTP_SECURITY is invalid. It needs to be one of the following options: starttls, force_tls or off

HAd you enabled and configured Notifications on Nethserver settings menu?

Generally, Vaultwarden has an issue whereby, if SMTP configs(env) are present, they must be configured, and when configured they will be used.
Also seen here: Fix Vaultwarden + Add Configs by iamEvanYT · Pull Request #2293 · coollabsio/coolify · GitHub
SO maybe we need a message that Notification settings need to have been configured on the server first, for Vaultwarden to start?

Is None the default with NS if mail instance is selected? here

At first try it was disabled, at second try I enabled it and chose my mail server instance for notifications.

Yes, I think so.

Yes, if there’s no way to use it without mail.

@mrmarkuz could you test with Manual configuration as the configuration on the email notifications settings?

After manual configuration of the notification settings the app is starting.

1 Like

so i guess the issue seems to be within the Use Mail app instance option,

When you’re using the local mail instance for notifications, the encryption is set to none via the variable SMTP_SECURITY.
But the variable SMTP_ENCRYPTION wants “off” instead of “none”.

So you need to set SMTP_SECURITY to “off” when SMTP_ENCRYPTION is set to “none”.


Okay let me check

1 Like

So I installed the vaultwarden test package and when I configure it and try to go to the link in vaultwarden dashboard node that ties to take me to the app via web I get the following.

Here is internals of it… I do notice it says vaultwarden services shows failed?? and then it also says in the logs Error loading the configs…

Any ideas whats up and how to fix it?


Are you using latest version
if yes enable smtp in your server

1 Like

It worked…

Now I tried to use the admin portal. Of course it asks for a token. I found it and tried to put it in… but it says it is not correct. What do I do now?

weird issue try reconfiguring second time
if persits let me know also can you check the logs

1 Like

What does this mean please?

Here’s the logs …

Looks like it is still a problem…

Do you mean saving settings again under settings or uninstalling then reinstalling vaultwarden?


Hay LayLow…

You need to go to settings and email notifications and set it up…

Hope this helps.


1 Like

Still can’t get the admin token to apply. Not sure what to do now.

when you set the admin token, and save the config, they dont work ?

Edit, its interesting setting YourReallyStrongAdminTokenHere seems to work fine,

but if i put some other short content it does not, could the length have an issue?

After Further investigations, i Have noted, the length is not the issue.

The Admin token Actually works just fine, However, setting anything else other than the initially Set Admin toke seems not to Work.

HEre is a test case.

Install Vaultwarden Afresh

Configure a Defined Admin token.

Access the admin login page, and login with the token.

The login works fine.

GO back to Ns setting page for vaultwarden, and change the token to somethign else.

Go back to the login page for admin, the token does not seem to work.

Go back to setting page, and revert the token back to the original token.

Then go back to vaultwarden admin page.

The Token seems to work Again.

So does anyone Have an Idea why this Happens.

I have Vaultwarden in another server, not NS related, and i seem to be facing and almost similar challenge.

    image: 'vaultwarden/server:latest'
      - 'vaultwarden-data:/data'
        - CMD
        - curl
        - '-f'
        - 'http://localhost:80'
      interval: 2s
      timeout: 10s
      retries: 15

so What gives.

Saving under settings

Oddly it will not allow me to copy and past the token. So I had to copy it down then enter it manually. When I try to enter it and I select enter it returns the following - “Error: Invalid admin token, please try again”

So I am at a stand still as I can not get past this issue…

@kemboielvis22 I did try save the setting but still get “Error: Invalid admin token, please try again”

Seems like your saying uninstall it and reinstall it… correct? okay. I will uninstall it then reinstall it then and see if I can enter it in.

I will let you know what happens.