File and Printer Sharing Problem

NethServer Version: 7.9.2009
Dear All I have NS7 setup as my AD (Samba AD)
Client Machines are all Windows - Mix of Win10 and Win7, and all have joined to the Domain which were earlier using the local Workgroup, sharing local folder’s and printers (USB).
After Domain migration, all Printer sharing is not working any more.
From Client1 if I try to access Client2 share, I am unable to connect, since the authorization fails

Did you try connecting with DOMAIN\username or username@domain?

Does it work when using IP address instead of name like \\\share?

Does it work with admin(istrator) user?

I tried DOMAIN\username andusername@domain both. The problem seems to be strange. Sometime it gets connected and only show netlogon and sysvol folder, after I did gpupdate to both the client PC and sometimes it shows

. I could browse the remotepc client cdrive and even create file or folder. client PC some clients can do things which needs Administration authentication, without asking any. Some clients were able to get connected with printers. What’s happening is out of my reasoning. Talked to @Andy_Wismer but his all clients have networked printers and never faced such issue.

The remote client has printer share only, but I was able to browse all drives.Havent checked with the IP but Auth with user admin fails

These shares are usually on the DC not on the client. For the server shares you need to connect to the Nethserver, not the NSDC.

Are you using group policy as regards the shares?

Could it be that there are working saved credentials on some clients?

Are the permissions ok on the clients? Usually domain admins should be in administrators group and domain users in the users group.

Please also check logs in event viewer to maybe get more info.

Maybe you need to allow SMB 1.0 for accessing the printer (just a blind shot):

1 Like

Yes I understand that the Shared folder in NS and the NSDC is the Samba running in Container of NS with different IP.

No it was just random try.

admin is the domain administrator and all users in domain user group.

Event viewer of client PC or logs I. NS via cockpit ??

Want to avoid SMB 1.0 due to crypto threat, I dear most.

One important cause could be DNS problem. The whole network DHCP is managed by ISP provided Microtik router. In a trial, I removed all DNS server entry in client except NS IP, did ipconfig / flushdns, delete all saved credentials in client. But still the client had the internet access and could resolve the web address. May be the router somehow is able to override all DNS

Yes, the MS eventvwr on the client.

NethServer should be DHCP/DNS server for your clients to avoid problems.

That’s normal. If the client uses a working DNS server the internet access is still alive. It’s important to use the Neth DNS server because it knows about your AD.

I have returned from the Site, but was able to pull some of the event event from the client PC’s. which indicates the DNS problem. Why some clients works and joined the Domain on the first place ??
The only reason I could think is the topology of the Network, which have 3 Camrack, with dual gigabit unmanaged switch 24port each, and the client’s are separately distributed. The total number of PC’s are 35, and the ISP router lan is connected to a Switch. The Server position is setup away from that switch, through which Router is connected. Several stray network wires indicates, the possibility of the Dual network wire connecting to switches (Loop).

Is it possible that the client, when try to reach DNS1 i.e NS timeout, and Router’s DNS which is DNS2 or Alternative takes the control. I have a working Server 2012r2 in my Present working Site, and Pfsense is working asDHCP and Secondary DNS along with the AD DNS in a single network, and never faces any issue.

Any other alternative, since the Server is Shutdown at night, but need internet for the Cameras.

At least the clients should use only NethServer as DNS and NethServer may use the router for DNS.
I don’t know about pfsense but it should be possible to use the Neth DNS for specific domains like the AD domain.

Is the Nethserver the local AD server or domain member?

Do you mean disable DNS of the router, and enable DNS in NS7. In client first DNS should be I.p of NS and secondary Google DNS. Not to mentioned all are connected in one IP pool 192.168.1.x.

The company I am working have two unit, in first unit we have Server2012r2 as local AD and everything is working fine. I am using PFSense for firewall and have DHCP and DNS active. The client PC in our first unit have two DNS entry, one is The Server 2012 i.p and secondary as PFSense i.p. All external DNS of client desktops are blocked by PFSense, and it itself uses Google and opendns by its resolver.

And after reading about Nethserver, for our second unit I decided to go with Nethserver installed in Proxmox which will be the Local Samba AD. The server is Dell Server 8 core 16 GB RAM 2 TB hard disk with Dell Perch Raid. Have setup Synology NAS as backup in its NFS share for NS7 using duplicity. A USB HDD attached locally with the Server act as the backup for the Proxmox VM. Have 40+ clients which are using NS file folder share all mapped to their desktops and permissions defined on basis of department or group. Rsync keeps another copy of Fileserver in a shared folder of the NAS and clients have read only permission to recover any data if deleted. Have 40+ users and the location is different than the main unit. And now I am fucked up since the shared printer is not working.

My problems are

  1. Usb shared printer not working, nor local share folders.

2 File server performance poor. May be due to ext4 instead of xfs, but I cannot change it now. @Andy_Wismer talked about installing the VM in NAS share, but then what would be the use of the Server storage. Means now would you backup data of the NS VM in NAS to server and not the other way around.

  1. Backup taking long time.

  2. Remote location, can work online only.

  3. Working environment, and users can’t be disturbed. At night the office is closed, with no power. And need solution quick.

  4. Can I manually add the DNS entry of the desktop sharing printer and it’s IP in NS just how I did the two entry of NSDC and NS.

No, I mean to let the client use only Neth as DNS server (just for testing, maybe the Google DNS is the problem?). No need to change anything on the router.

I tried to reproduce but shares and a shared printer on a client PC are working from another client PC.
Both clients are joined to the AD.
Can you reach the AD domain from the clients? Try more often and from different clients to check if it’s always resolvable:

ping ad.domain.tld

Don’t get me wrong, but what about buying a network printer to avoid printing via a clients USB port? At some point your troubleshooting costs more than the printer.

Did you already check your hardware for errors?
It’s a common concept to use a NAS for VMs. In your case it may solve the poor perfomance problem.
I think it’s ok to use the local storage for VM backup.
BTW, please try to make “talks” public because it helps the supporters to get more information to help you. Private threads are intended for sending private things like public IPs or information you don’t want to be public.

OK but as you virtualized the Neth with Proxmox, it should be possible to move the VM or try other things. I hope you can wake up a client for testing…

No power at night is very hard because of the limited time frame for you to work. Isn’t there a possibility to change that, at least for the time of troubleshooting?

Yes but which DNS entries regarding NSDC and NS did you enter? This is usually not needed.

Isn’t this thread Public

It is, but you seem to have talked with @Andy_Wismer and there may be some information missing in this thread. This may lead to supporters telling you the same as Andy already told you which is ineffective. It would be easier to do it in public because you get a bigger chance that the support people can solve your problem without going through the same steps as Andy.
More thinking brains are better than one.




I’d just like to confirm that we exchanged a (my) Anydesk Nr, and talked over Telegram…
And we did not record the Telegram conversation - my bad… :slight_smile:

No, I don’t think anything essential is missing here…

My 2 cents


Yes, for security I keep that discussion private, even talked to him over telegram and he remotely helped me in setting up USB storage.

No problem, it was just an advice, I did not know how you were connected…

1 Like

Just trying to help, and waste less time of three people… :slight_smile:

PS: The USB Storage was on top of things on a Proxmox, not a Neth… :slight_smile:

Yes my bad.

1 Like

Sorry, but @Andy_Wismer was himself very busy, I was stuck, and fucked up with whole office setup disturbed, and no known one to support.

1 Like

No problem and nobodys bad @nio707
Let’s face the issues you have. Did you try anything of the steps like ping domain or move VM?