Error when reinstalling FreePBX

NethServer release 7.7.1908 (final)
I installed FreePBX, did a module update in the web ui of FreePBX and got some error.
Then I deinstalled FreePBX but when I try to reinstall FreePBX again, I get an error:

echo ‘{“action”:“install”,“packages”:["@nethserver-pbx"]}’ | /usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update | jq

How to fix this?

That’s always been my experience when I’ve tried to play on FreePBX under Neth. You might be better off installing the FreePBX distro (see in a VM, which Neth can manage handily.

Does noone use FreeBPX in Nethserver?
Is it not allowed to update? Then this should be documented, otherwise the bug should be fixed.

Sorry for late answer. You are right, it’s a mess with uninstalling. Here are some instructions:

For updating freepbx:

Command line:

Preparing for working module admin (don’t know if still needed)

It’s mostly a permission problem.

Is there a useful result when you enter that on command line?
Did you try with yum too?

When entering the following command it hangs forever and doesn’t output anything:
/usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update

When entering the following command it returns immedtiably, but also no output
/usr/bin/setsid /usr/bin/sudo /usr/libexec/nethserver/api/system-packages/update

When I install with
yum install netserver-freepbx
I get not error, but are not able to login into the GUI with root

I tried to reset admin password:
When I try:
fwconsole unlock t3jpc7aie2ci1ud9peoh9uk5k1

I get the output
PHP Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{’ or ‘' in /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php on line 90 Whoops\Exception\ErrorException: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '’ in file /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php on line 90
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/freepbx/admin/libraries/Composer/vendor/symfony/translation/Translator.php:90

Sorry for late answer. Here is a possible solution: