Error SOGo update

NethServer Version: 7.8.2003
Module: SOGo

I started updating my server over yum but get an error over module SOGo. Despite all steps are followed according the result is the same.

Error message: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.

Any suggestions?

v3 an v4 nightly repos are removed/discontinued by Officially supported versions are v2 and v5.

Time to upgrade to v5?
cc/ @stephdl

Wait till the nethserver-sogo package maintainer can evaluate how to proceed.

So I modified the sogo.repo file and ran the update command.

Outcome is that a public key is missing. How to get this one installed?

Package Arch Version Repository

sogo x86_64 sogo5 20 M
sogo-activesync x86_64 sogo5 140 k
sogo-ealarms-notify x86_64 sogo5 16 k
sogo-tool x86_64 sogo5 58 k
sope49-cards x86_64 sogo5 206 k
sope49-gdl1-contentstore x86_64 sogo5 67 k

Transaction Summary

Upgrade 6 Packages

Total download size: 20 M
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for sogo5
warning: /var/cache/yum/x86_64/7/sogo5/packages/sogo-activesync- Header V4 RSA/SHA1 Signature, key ID a0030e2c: NOKEY
Public key for sogo-activesync- is not installed
(1/6): sogo-activesync- | 140 kB 00:00
(2/6): sogo-ealarms-notify- | 16 kB 00:00
(3/6): sogo-tool- | 58 kB 00:00
(4/6): sope49-cards- | 206 kB 00:00
(5/6): sope49-gdl1-contentstore- | 67 kB 00:00
(6/6): sogo- | 20 MB 00:04

Total 4.4 MB/s | 20 MB 00:04

Public key for sogo-ealarms-notify- is not installed

I seem to have missed your advice, so I’ll wait a bit

I guess it is this (from SOGo FAQ):

rpm --import ""

Better safe than sorry :wink:

As I’am a bit curious, I took a snapshot and tried to import the key. Unfortunately this import command points to a none excisting key as far as I can see. Outcome is “import read failed (2)”
So I’ll be waiting till you expert found the solution :grinning:.

We provide stable rpm of sogo, we build them ourself

Recently we released sogo 5.0.0

1 Like

Error message:
Public key for sogo-tool- is not installed
and the SOGo faq command to import the pgp still gives the same error

clearing cache solved this one now start testing version SOGo 5.0.0.

First impression: all works fine, IMAP en webmail tested so far

1 Like