[Errno 256] No more mirrors to try

v7
updates

(fpausp) #1

NethServer Version: 7.6

Cannot get polkit…

[root@neth13 ~]# yum --enablerepo=* clean all && yum update -y
...
Error downloading packages:
      polkit-0.112-18.el7_6.1.x86_64: [Errno 256] No more mirrors to try.

Any suggestions?


Updates problem
SoftwareCenter Problems (update not working, modules not shown)
(Michael Kicks) #2

Same problem here. Updated an installation without a flaw, the second one went the same way as yours.
I’ll try tomorrow if some mirrors will be updated…


(fpausp) #3

I’ll do the same…


(Marc) #4

This early morning I’ve received a related message from anacron:

/etc/cron.daily/0yum-daily.cron:
Some delta RPMs failed to download or rebuild. Retrying..

Right now, on a test machine, it is getting this (excerpts):

Some delta RPMs failed to download or rebuild. Retrying..
polkit-0.112-18.el7_6.1.x86_64 FAILED                                          
http://mirror.gadix.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable
Trying other mirror.

Error downloading packages:
  polkit-0.112-18.el7_6.1.x86_64: [Errno 256] No more mirrors to try.

Haven’t tried, but I guess the update will work by disabling deltarpms until CentOS repos are fixed.


(Michael Kicks) #5

I’ll wakeup the kitten for a shot.
And… yum update --setopt=deltarpm=0 rolled with a double six as result.


(fpausp) #6

Still not possible, is someone fixing it? I would need it on Mo to be able to install a new Server with all modules/updates…


(Davide Principi) #7

polkit reinstall succeeded here! This is my repolist -v output excerpt:

Repo-id      : ce-updates/7/x86_64
Repo-name    : CE-Updates-7.6.1810
Repo-revision: 1553029836
Repo-updated : Tue Mar 19 22:24:18 2019
Repo-pkgs    : 1,457
Repo-size    : 6.8 G
Repo-mirrors : http://mirrorlist.nethserver.org/?release=7&repo=ce-updates&arch=x86_64&nsrelease=7.6.1810
Repo-baseurl : http://mirrors.prometeus.net/centos/7.6.1810/updates/x86_64/ (9 more)
Repo-expire  : 21,600 second(s) (last: Fri Mar 22 10:11:22 2019)
  Filter     : read-only:present
Repo-filename: /etc/yum.repos.d/NethServer.repo

(fpausp) #8

Did it manually:

wget http://centos.mirror.garr.it/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm

yum localinstall polkit-0.112-18.el7_6.1.x86_64.rpm

yum --enablerepo=* clean all && yum update -y

Nevertheless, it should be fixed?


(Michael Kicks) #9

IMHO someone (in CentOS organization) should understand that DeltaRPM has to be regenerated and mirrored… anyway i were able to update when i posted the command…


(Dan) #10

Much simpler way:

yum install http://centos.mirror.garr.it/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm

And yum localinstall is never necessary–a simple yum install does the job.


(James Nesbitt) #11

Update: This polkit issue appears to have resolved itself sometime on Saturday afternoon.


(m_farlotta) #12

this is my netserver version (NethServer release 7.6.1810 ) but in cli ssh the system no recive update
t


(Stojovski) #13

rpm -e polkit --nodeps
than yum install polkit
than yum update
and all ok.


(Dan) #14

Why? The error messages (when they were happening; they appear to be resolved now) give you direct URLs to the package on any of several mirrors. All you have to do is what I posted a few days ago: yum upgrade <URL> to take care of that package, then yum upgrade again to get the rest of them.


(Stojovski) #15

I don’t know why, but i installed today fresh, and that come again.
After uninstall with no dependencies, and installed with “yum install polkit”, Nethserver7 installed was the version polkit-0.112-18.el7_6.1.x86_64.rpm, than worked all others.