Dolibarr 14.0.2 is waiting testers

yum install

A new version to test, I think we will enable the repository now or I will use directly the stephdl repo

Please have a go


Great, thank you @stephdl

upgrade or direct install ?

fresh install



Updated my 13.0.4 home instance.
No errors during install:


No user can log in.

I am using AD.

My 2 cents

can you find error in


something interesting in

/tmp/dolibar* log


It looks like the errors are due to “recreating” the used database, at least from /tmp/dolibarr_install.log…

I’ll see if I can provide you with both files - you’re better at analyzing app logfiles than I am! :slight_smile:

1 Like

I try to reproduce

@fausp do you use internal, ldap or SAMBA ad authentication ?

I can remember the same problem with an older version, please show us the exact credentials…

I use Samba AD.


So far, using either admin or aw worked, nothing further.
I never used eg admin@ or such, just only admin.

AD is defined as such:


Same VM, running on Proxmox.

Previous (working) Dolibarr version: 13.0.4

My 2 cents

Give me a second I will start the testserver…


No hurry! Even two seconds is no issue!

This is all on Proxmox, a rollback is no issue. No risk here of data loss!

And - I’ve sent Stephane the logs he needs.

My 2 cents




Looked the same here:


This worked before the update - no issues.
Since the update, I get this when I hit ENTER:

At the moment I can’t provide a screenshot of the users page, as no user can log in… :frowning:

I am sure @stephdl will fix this, see you tomorrow…

1 Like

hello just back at home right now, a bit late tonight

@Andy_Wismer good to know you can do a snapshot. I cannot reproduce and like @fausp it worked at the first shot

Indeed I can read in the install_log the warnings below repeated multiple times, no warning during the installation :expressionless:

2021-09-23 16:42:45 ERR ???@root DoliDBMysqli::query SQL Error message: DB_ERROR_NOSUCHFIELD Unknown column 'u.datelastpassvalidation' in 'field list'

can you do

rm -f /usr/share/dolibarr/documents/install.lock
go to the URL

check if you can do an upgrade of the db :slight_smile:

The above made no issue.

I’m using a custom vhost for Dolibarr, how do I access the /install URL?

This is what my browser normally shows (Dolibarr login screen)

So how do I access the URL https://YourIP/dolibarr/install
If I put in the IP, it will not work… ?

Found it!

1 Like

No luck…

I don’t think a reboot would make much difference…

My 2 cents