DNS Issue (probably bug)

NethServer Version: NethServer release 7.3.1611 (rc3)

I cant solve this problem it appeared when i tried to install backup module but something went wrong.
I cant update or see modules list !!

does your server is connected to the WWW ?
in a terminal do

ping google.fr

host google.fr

1 Like

Hi Sebastian,

have you entered the gateway in the settings of the network card?
I had the same problem a few days before.Then I entered the gateway and it worked.



1 Like

and i tried to make a file_get_contents($url) using php and the result is:

Failed to connect to server: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) Failed To Connect…!!

therefore you know why the software center doesn’t work, your server doesn’t get access to internet. Now you have to understand why your network configuration is not good, but for this you need to explain what you did, and where your server is (virtual, real, IP configurations…)

what is the output of
db networks show

@davidep @giacomo what about dignostic tools in the server-manager to test if the server gets access to the internet (traceroute, ping, nslookup)


can you ping the gateway


does the IP is still good ?

somewhere I read that your server is online on ovh if I recall well ?

What is the output of

ip addr

ip route

I saw that recently you added an ip alias Change the IP of one of my Virtual Hosts in OVH

Does the problem started here :-?

1 Like

I added an IP alias but the problem started previously.
I saw the notice when i tried to install the backup module and the italian language module from software center but the problem could started previously when i tried to create the ip alias and by mistake i deleted the eth0 and after i reset it and al looked ok so i tried to install modules but [Errno 256] apeared


1° I deleted eth0 by mistake
2° I reset eth0 and it looked OK
3° I tried to install modules but [Errno 256] apeared

Ping to ->

-The server is online


It seems a dns problem and not a network problem

what about nslookup google.fr

[root@NS7DEV ~]# nslookup google.fr

Non-authoritative answer:
Name:	google.fr



1 Like

bingo dns problem; which dns you use ?

1 Like

config show dns

what is the output ?

config show dns

1 Like

[root@hosting ~]# config show dns

change it to by the server-manager and try it again

1 Like

[root@hosting ~]# config show dns

then ping google.fr

[root@hosting ~]# ping google.fr
ping: google.fr: Name or service not known

output of nslookup google.fr