Dns hardcode brings unattended install to a halt now

fresh unattended install, dns blocked at network gateway dhcp server, install freezes here.

I know we’ve discussed this before, I forgot and started up a test instance and it took me a bit to remember why after killing the instance and then starting it anyway, when I couldn’t clear the yum cache error I remembered the dns hard code.

I then put the pass rule for the test instance above the block dns rule in the gateway and installed unattended again, completed successfully and applying updates.

Sorry, but I don’t remember this discussion :frowning:

Could you please tell me a bit more?
Just a couple of quick points!
Thanks! :pray:

start here…
Continuing the discussion from Try out NethServer 7 alpha2 ISO!:

1 Like

So you’re shutting down the system when it hangs?

I think I also hit the same symptom with squid… I’ll try to reproduce it!

That was initial install, pre reboot post install, pre first run, I let it set for 20 minutes before I just killed it, I then booted it and it came up fine, even finished the first run from the gui and ran updates… then I wiped it with a reinstall after allowing the instance to access outside dns. @davidep

1 Like

I can’t reproduce this problem: the DNS should not be involved in any process during install and first configuration.
I also tried to remove the Google DNS from the ISO and it seems to work properly, but honestly nobody else raised this problem and I would like to avoid changes on something which already works.

Probably we should search elsewhere for the cause of install process hang, but I don’t where to start since I can’t reproduce it :frowning:

Just tried and can’t reproduce event his one.
If something hangs, please check the logs and the console to see what’s happening.

1 Like