Default Mailaddress in Sogo 3.2 can't be set


NethServer Version: 7.3.1611 (Final)
Module: Version 3.2.4 (mockbuild@nethdevc.havak.lan 201612041407)

in a multidomain scenario it is important to set the users default email address for outgoing mails, because the created user in NS would get the servers default domain not matching with the users email domain. To solve this, the user will then get a mail alias for his real email domain.

Now, when you try to config Sogo to use his email domain you can enter this information here (field

After you saved that setting you will see, that it isn’t saved and not provided as first choice if you create a new mail (drop down menu to select your email/alias). As far as I remember in Sogo version 2 this was working well.

Is it a bug?

I can do it with 3.2.6a

only the email field can be changed of course, the account field is a mandatory

Can’t update, nothing is installed:

[root@dc2 ~]#  yum install nethserver-sogo --enablerepo=nethforge-testing
Loaded plugins: changelog, fastestmirror, nethserver_events
base                                                                         | 3.6 kB  00:00:00    
centos-sclo-rh                                                               | 2.9 kB  00:00:00     
centos-sclo-sclo                                                             | 2.9 kB  00:00:00     
epel/x86_64/metalink                                                         |  25 kB  00:00:00     
epel                                                                         | 4.3 kB  00:00:00     
extras                                                                       | 3.4 kB  00:00:00     
nethforge                                                                    | 4.0 kB  00:00:00     
nethforge-testing                                                            | 2.9 kB  00:00:00     
nethserver-base                                                              | 2.9 kB  00:00:00     
nethserver-updates                                                           | 4.0 kB  00:00:00     
updates                                                                      | 3.4 kB  00:00:00     
(1/3): nethforge-testing/7/x86_64/primary_db                                 |  23 kB  00:00:00     
(2/3): epel/x86_64/updateinfo                                                | 727 kB  00:00:01     
(3/3): epel/x86_64/primary_db                                                | 4.5 MB  00:00:06     
Loading mirror speeds from cached hostfile
 * base:
 * epel:
 * extras:
 * nethforge:
 * nethserver-base:
 * nethserver-updates:
 * updates:
Package nethserver-sogo-1.6.2-1.ns7.noarch already installed and latest version
Nothing to do
[root@dc2 ~]#

any idea?

The right command is:

yum --enablerepo=nethforge-testing update

Already tested :wink:

1 Like

okay, i have updatet sogo to 3.26 a but already have the problem, that i am not able to change the local domain to external domain for sending emails. it always use the internal domain… any ideas? have figured out that it only happens when i send from the outlook client or active sync devices, from web interface it works

Would like to test, but I need to be able to downgrade to old version later.

If I run:
yum --enablerepo=nethforge-testing update

How can I downgrade to old version then?

 yum downgrade packagename
1 Like

thanks, too easy to recognise :relieved:

I’m now on Version 3.2.6a and tried again what I described in my top post. I can’t see any differnence. I still can not store my email.
I press ‘OK’ button inside IMAP, then store again on top right ‘disc’ button. Next I switch to email, then back to settings to verify what’s inside IMAP. Still the default email (= account name) appears.

On my side I can give whatever I want as email-adress, all is stored as long an @ is included. If I logout and in again, everything is as I stored it before. I also tried an external imap acoount and it works perfectly.
Maybe your problem is related to database access?

1 Like

I tried a different user and Sogo was working well. The problem only exist for a single email address as far as I can see.
The not working email addr. was maybe used somewhere else during installation. It is a valid one, because it’s my own.
Here what I found in sogo.log when I save a working one (a lot of warnings but it’ works?!):

Feb 02 15:28:15 sogod [1230]: <0x0x7f56395b7ac0[LDAPSource]> <NSException: 0x7f563aa6fb20> NAME:LDAPException REASON:operation bind failed: Invalid credentials (0x31) INFO:{"error_code" = 49; login = "samaccountname=schloegl,dc=intern,dc=org"; } 2017-02-02 15:28:15.134 sogod[1230:1230] ERROR(-[NGLdapSearchResultEnumerator nextObject]): does not support result references yet .. 2017-02-02 15:28:15.187 sogod[1230:1230] ERROR(-[NGLdapSearchResultEnumerator nextObject]): does not support result references yet .. 
Feb 02 15:28:15 sogod [1230]: <0x0x7f563aaf4fd0[SOGoSieveManager]> WARNING: Could not delete Sieve script - continuing...: {RawResponse = "{ok = 0; }"; result = 0; } 
Feb 02 15:28:15 sogod [1230]: "POST /SOGo/so/schloegl/Preferences/save HTTP/1.1" 200 0/3102 0.467 - - 0

and here much shorter if I try to save the one which can’t be saved:

Feb 02 15:31:26 sogod [1230]: "GET /SOGo/so/schloegl/editAccount?account=0 HTTP/1.1" 200 1818/0 0.003 7825 76% 0 
Feb 02 15:31:55 sogod [1230]: <0x0x7f563a73ea60[SOGoSieveManager]> WARNING: Could not delete Sieve script - continuing...: {RawResponse = "{ok = 0; }"; result = 0; } 
Feb 02 15:31:55 sogod [1230]: "POST /SOGo/so/schloegl/Preferences/save HTTP/1.1" 200 0/3103 0.263 - - 0
1 Like

Sorry, I can’t reproduce. But I have the same messages as you:

Feb 02 16:10:24 sogod [12362]: <0x0x7f76aaa3f660[LDAPSource]> <NSException: 0x7f76abb1b790> NAME:LDAPException REASON:operation bind failed: Invalid credentials (0x31) INFO:{"error_code" = 49; login = "samaccountname=jeckel,dc=ns7,dc=lan"; }
2017-02-02 16:10:24.255 sogod[12362:12362] ERROR(-[NGLdapSearchResultEnumerator nextObject]): does not support result references yet ..

I don’t think that this is the reason for your problem.

My email which could not be set in Sogo was used in AD (my NS is a PDC for windows). See here:

I deleted this entry from AD and I could set my email in Sogo. Sogo reads something from LDAP database.
Pls. check if you can reproduce this and in case off, I would call it a bug. People usually use this field in AD.

1 Like

Hello hucky,

IMAP on outlook 2016 for an account with a mail alias works for me. The only thing important is to use the user server domain to authenticate (user@serverdomain), but you can use the alias as mail address. If I analyse the mail header of the email I receive, I can see (Authenticated sender: user@serverdomain), but this is harmless, everything else is pointing to the mail alias. So for me this works as it should. Hope that helps.

Hey Andreas,
at my side (with outlook2013, android devices, ios devices) everything went well. I have Contacts,Calendar and Emails. the only thing what did not work is if i send emails to an external domain, then i get from outlook,android or ios the mx error. when i use the webgui it works also fine cause it use the adress i put in as answering address.

I don’t have an outlook 2013 here, but listen to this:

Are you using a Smarthost to send mails out into the world?
The Smarthost connects (with login data) to you provider you have registered a domain/mailbox?
In this case typically the provider would only accept mails coming from your registered domain, not from any other because of spammer protection.

To verify the reason we should first check your outlook settings. Can you post it here?
Then when you get back the error msg you should post the mailheader here that we can see who reports the problem and what email is used to send out (guess you smarhost reports it).

Also in my mailheader I can find (Authenticated sender: user@serverdomain). Maybe this is why your smart host wont forward the mail, because here you will find you internal server domain.

1 Like

yes, of course i have an registered mailbox etc. and also the outlook settings are okay. The most ISP´s are checking the domain from sender if it exist or not, this is the problem, from webgui sogo takes the mailadress from the registered domain, only from the devices with android, ios or the outlook client it has that error. it works before, i guess with sogo something has changed. in the past i changed the domain in sogo.conf and it works, now it dont work.

if you send out by imap is sogo involved at all? Or do you use active sync?

i use activesync

OK, then Sogo and/or NS will create the mail header used for the outgoing mail. The difference will be in the mail header. Have a look into! The mail sent back from your smarthost will include it.