Concurrent backup is still running

Dear everyone, I am Nirosh and back again to NS as my company needed to impliment a server to Centos 7.
The first problem I here by getting involved with data-backup.
I have set data backup to keep backups 2 weeks (14 days) hoping that it will continuesly do incremental backups like SME server. But unfortunetly at the 8th day my NAS drive was out of space because the backup was executed as full.
then I deleted NAS drive full backup data of 8th day and disabled backup on server.
but the backup mount point cannot be unmounted it shows up in mstab file. It keeps existing everyway around.
I followed Concurrent backup is running link to resolve but still the backup mount point is existing and no other backups can be set on the server. Someone help me to find out where I have missing the point to stop this concurrent backup process and to unmount the backup folder.


welcome back.

Did you setup other backups than duplicity? The link you followed only cares about duplicity backups.
Does a server restart help? That should force stopping all running backups.

In server manager you can choose between full and incremental backup:

Maybe ‘lsof’ could show you what process still has an open handle to your NAS stopping the umount.


1 Like

Thanks for the reply you two. As mentioned above by [mrmarkuz] I have setup another duplicity backup but when I run this backup the following error is popping in the log.
Backup: incrbackup
Backup started at 2020-04-11 22:30:01
Pre backup scripts status: SUCCESS
umount: /mnt/backup-incrbackup: not mounted
Backup directory is not mounted
Can’t mount /mnt/backup-incrbackup
Action ‘backup-data-duplicity incrbackup’: FAIL
Backup status: FAIL

"Before I start this backup i checked the NAS drive availability and access permissions."

I also have the ego to know what is the EddieA’s option, how to isolate the problem using “lsof” command?

Maybe it helps to mount manually?

mrmarkuz, thanks for your solution. I used umount command to unmount the cifs mount point from the server.
umount -t cifs -l /mountpoint/

Thanks for the help.

1 Like