Collabora CODE 21.11 testing

Please test the new Collabora CODE 21.11, see announcement.

There are also some changes under the hood, for example the service name changed from loolwsd to coolwsd, see following thread for more details:


yum install nethserver-collabora --enablerepo=nethforge-testing


yum update nethserver-collabora --enablerepo=nethforge-testing

Test case 1

  • Fresh install
  • Check if documents are editable

Test case 2

  • Update collabora
  • Check if documents are editable
  • The old config db entry loolwsd shoudn’t exist anymore

See also:


I will try to find time tomorrow…I would love to see people also in the run

not so hard to keep somewhere a VM ready to help developers

1 Like

Would a split test work IE having NC hosted on a TrueNAS server while Collabora is hosted on Nethsever be acceptable?

1 Like

Yes, please test if it works when used remotely.
As collabora configures the local NC app, a test with local Nextcloud is needed too I guess.

1 Like

In-place upgrade from:

The upgrade via CLI was successful. From my NC instance hosted on TrueNAS, an error occurred:

Not Found

The requested URL /browser/b5534c4/cool.html was not found on this server.

Resolved the issue by resetting Virtualhost settings using the new coolwsd tool:

config setprop coolwsd VirtualHost
signal-event nethserver-collabora-update

I did have some odd missing icons, might be my reverse proxy setup.

1 Like

hum the upgrade path got some issue, the former installation was working but after I found in messages log

Dec  3 15:43:44 ns7loc10 coolwsd: wsd-08704-09869 2021-12-03 15:43:44.748806 +0100 [ websrv_poll ] ERR  #21 Exception while processing incoming request: [GET /cool/ HTTP/1.1#015...]: Invalid or unknown request.| wsd/COOLWSD.cpp:2827

I am diving :slight_smile:

1 Like

I need a reboot to make it works … why

1 Like

@mrmarkuz I need to trigger the event : signal-event nethserver-nextcloud-update to solve the issue above after the upgrade

@mrmarkuz do not ask me why but at the end of the upgrade you have to launch to avoid the error

[root@ns7loc10 ~]# systemctl restart rh-php73-php-fpm

I think we could safely add it to the createlinks…


in fact maybe rh-php73-php-fpm is not installed on the server, collabora can be remote of the nextcloud installation, by the way, a reload is working also @mrmarkuz

1 Like

total victory for the install path :smiley:

1 Like

I can confirm this with my test above.


Thanks for testing!

An update issue was fixed so please test the collabora update once more. Thanks in advance!

yum --enablerepo=nethforge-testing install nethserver-collabora

1 Like

I am testing it :smiley:

1 Like

good for the upgrade and the installation of nextcloud and collabora on the same host, what about the remote collabora/nextcloud host ?

1 Like

Thanks for testing!

It’s the same command but the Nextcloud collabora app needs to be setup manually.
You need to set the allowedwopihost db prop to the Nextcloud instance domain name.

I tested it and it’s working.

I’ll add a line to the collabora docs about remote Nextcloud config.

1 Like