Changing file size of attachments received in Webtop

Hello Forum,

@support_team @webtop_team @lucag

I’ve read this post as well as this nethserver document:

To help me change the max attachment size so I can receive an email with an attachment that is larger than 10mb. I added to my Admin Panel a new Service for com.sonicle.webtop.mail and a key of attachment.maxfilesize. For this size I added a value of 15728640 for 15 MB.

But when I send a test email with an attachment of 12 MB I still receive a reply saying the size of this email is too large for my Webtop Mail to receive.

What am I missing?

Thank you.

Hello @support_team or @webtop_team ,

Please assist with how I change the settings in Webtop to allow for files to be received that are 15 MB or smaller. I tried updating the Admin Properties but I still get an error when I try to send in a file that is under 15 MB but over 10 MB.

Thank you.

Did you set the “Maximum Message Size” in the mailserver settings?

1 Like

Hello @mrmarkuz ,

I thought that was for outgoing messages only. My Setting for ‘Maximum message size’ is currently set to the maximum of 1000 and I still have this issue. It doesn’t appear this setting has to do with the message being received into Webtop.

@webtop_team team, are you available to chime in and provide direction for us on how to increase the size of mail allowed INTO Webtop?

Thank you.

Did you try this?



Yes, that was the forum post I linked in my initial post. I’ve added “attachment.maxfilesize” to my Admin panel and I’ve made the size 15 MB in size. But still no dice. Any attachment between 10MB and 15MB on my system still won’t be received. I sent the test email from Gmail and Gmail received a response that the mail is too large.

Did you set the size in bytes?


I noticed that you set it correctly.


@greavette I tested it and set the attachment size to 50MB (52428800) and was able to send a mail with a 15 MB attachment, so please try to increase the allowed size just to see if it works, you may lower the value to fit your needs afterwards.

One needs to edit the system properties, not the domain properties.

Here’s my attachment size setting:


Hello @mrmarkuz , I really appreciate your continued support with my question. I’ve adjusted the maxfilesize property similar to what you did to 50MB. I ran another test from Gmail to my Webtop email. I’m sending a file with size 11,134 KB which is just over 11MB. Once again I received back to my Gmail a Mail Delivery Subsystem message that my email was too large. There must be something I’m missing here. Do I need to restart my Webtop/Nethserver for this maxfilesize to take effect?

Thank you.

Usually the settings are applied immediately but you can restart webtop by restarting the tomcat@webtop service.
Did you test if it works with another mail provider except Gmail?


Hello @mrmarkuz , @lucag , @webtop_team ,

I’m still struggling with increasing the maximum size of an attachment allowed to be sent into our WebTop mail. I’ve created in our Admin Properties a new property for com.sonicle.webtop.mail for ‘attachment.maxfilesize’. And I’ve made this 50 MB! Here’s a screenshot:

I’ve done many tests from Gmail where the maximum allowed email I can send into my WebTop is an email with a 7MB attachment. Everything larger results in an email back to my Gmail saying “Your message couldn’t be delivered because it exceeds the size limit. Try reducing the message size and resending.”.

I’ve restarted my Nethserver after setting the attachment.maxfilesize. Can anyone help me with what I’m missing? It’s becoming a real problem for us to have this max filesize limit.

Thank you!

@support_team ,

Please see the email I’ve sent to you regarding my issue. I sent an email today asking for assistance.

Thank you.

I figured out my issue. It was a restriction on my vendor’s spam filter. The correct location in Nethserver to set the size is in Email > Settings > Maximum message size.

Thank you to Nethesis support for your direction in helping me find the problem.