Cannot join QNAP to Domain

activedirectory
v7

(Eitan Orgil) #22

@robb
OK, thank you for clarifying that for me.
Now, with that in mind, why will the QNAP try to connect to the domain controller as: nsdc-dc.nsdc-dc.ad.mydomain.local?
Also, as I wrote in the beginning, in QNAP I have the error message:
[Security mode] Failed to join domain. Cannot resolve domain. Check DNS server, AD servewr name and Domain.
Cannot resolve Domain
What name should I put in the DNS?
The QNAP is configured to use the NS DNS:


the IP of 192.168.10.1 is the internet connection gateway


(Federico Ballarini) #23

Settings -> Win/Mac/NFS -> Microsoft Networking -> Advanced Options

Check settings in this page.


(Eitan Orgil) #24

@federico.ballarini
where? on the NS or QNAP


(Federico Ballarini) #25

Check on QNAP


(Davide Principi) #26

Do not set an host that’s not an AD domain controller as secondary DNS: it might lead to problems as it does not have records required by AD clients.

What is the FQDN of the QNAP? I’d expect something like

qnap.ad.mydomain.local

The domain suffix must match the AD one.

The DNS domain name of AD is ad.mydomain.local. You put the FQDN of the DC instead!


(Eitan Orgil) #27

@davidep
Well, this is the only name that will give me a domain server to choose when trying to connect to the domain, when I write ad.mydomain.local, I get an empty selection screen to choose from…(see earlier messages)


(Eitan Orgil) #28

The QNAP does not have that name as he is not a part of the domain yet…
I don’t know If i can write it’s FQDN or where to…


(Michael Kicks) #29

Do the QNAP NAS has the same computer/hostname that had before?
Was the Computer Account removed from the NSAD structure?


(Eitan Orgil) #30

@pike
Yes, the QNAP has the same name, and yes, the computer account was deleted from the NSAD structure


(Eitan Orgil) #31

Update,

I have installed a Microsoft Domain server and connected the QNAP to it with no problem.

To the best of my understanding, the QNAP is configured correctly, so the error is located on the NethServer, and probably in the DNS area.

Thank you all for your help so far


(Davide Principi) #32

This is possible but is not the only explanation, because others succeeded in a similar task.

This is bogus, for sure.


(Markus Neuberger) #33

You may try to disable strong auth:

Samba wiki:

https://wiki.samba.org/index.php/Updating_Samba#New_Default_for_LDAP_Connections_Requires_Strong_Authentication


(Michael Kicks) #34

Maybe I am wrong… DNS server used by qnap should be the container (nsdc) or Nethserver?


(Michael Dahlgren Nielsen) #35

I have the same problem on a QNAP TS-421 and a TS-453-PRO. Nor can I join the samba domain.
Have also tried all versions of FQDN, check that I can ping the domain compter as well as ad.domain.local also get an ip back. And I do.
I have to try all the tips here on this topic.
but have failed to get through :frowning:Udklip


(Federico Ballarini) #36

Hi @Michael_Dahlgren_Nie
First thing check that your QNAP firmware is up to date.

Do you need that QNAP will be a remote domain controller or only a member of domain? If you set a remote domain controller in read-only mode it should work.


(Michael Dahlgren Nielsen) #37

They have the latest firmware. The aim is that they should be medlemer of the domaine


(Michael Dahlgren Nielsen) #38

After i tried myself, with different combinations of name. is it new successful to get through the qnap domain wizard.
But now say that the domain is missing

Domain|624x451 Domain1


(Federico Ballarini) #39

Can you try to set up a domain not .local and use a domain.ext and join?


(Michael Dahlgren Nielsen) #40

So what you say is that i need to create a domain called .ext and not.local?


(Rob Bosch) #41

I think he means any other extention but .local
You could opt for .lan or any other outside world extention… (beware that you can get into DNS issues if you use a domain you do not own yourself)

/edit: link to an explanation why .local is not recommended: https://serverfault.com/a/811715