Cannot find a valid baseurl for repo: ce-base/7/x86_64

NethServer Version: 7.6.1810
Module: Software Center

Hello to all,
I haven’t written for a while in this community to ask for help.

I have a physical machine with a NethServer installation stopped for about a year.
Today I am trying to bring it to life. :slight_smile:

I tried to update it from software center or shell but I can’t.
The stacktrace that gives me is this:

#yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
Could not retrieve mirrorlist error was
14: curl#6 - "Could not resolve host:; Unknown error"

 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: ce-base/7/x86_64

I checked the network connectivity and everything seems ok.

The only anomaly is the resolution of hostnames.
If from shell I launch ping I get a valid answer instead if I launch ping
I get this as an answer: ping: Name or service not known

Do you have any suggestions for me to solve the problem?
I have tested all the suggestions related to similar posts but I can’t solve the problem.
Thanks in advance,

yum clean all --enablerepo=*

eventually if needed

rm -rf /var/cache/yum/x86_64/7/*

Hi Stéphane, thanks for the reply.
I had already tried to clean but did not give any result the error produced is always the same

what is the output of

[root@ns7loc9 Maildir]# host is an alias for has address

Check the dns servers, tryng ping and ip google dns

It’s the same:
[root@gateway ~]# host is an alias for has address

Instead, now if I use ping the result is ok.
Yesterday night it doesn’t respond correctly:
ping: Name or service not known

It’s things if the DNS worked intermittently
bah! :expressionless:

Take a chance for change DNS forwarders on NethServer. Which are you using now?

My NS instance is in the university network and I use university DNS servers. Do you have an alternative proposal?

Hi @pasing
We had a discussion about what DNS servers were used. You probably can find a few suitable for your need following that topic: Which DNS are you using?

I can recommend OpenNic

Thanks, Rob, I’ll look at your suggestions.