Cannot access computers on network when on VPN

yes, eth1 is NS

yes, I understand that NS needs to know which is the route … but my question is, what should I change (preferably via GUI) to achieve that. Because as already mentioned, I’ve activated both options - route traffic through vpn & allow client to client network traffic

For example:

if the remote site is: client-a and the network is mask

so you need into the /etc/openvpn/ccd/ a file


sorry … I don’t get that. I was not doing any such changes in the NS.
I’ve only installed it, did some initial setup - everything via GUI.
Do you think it is needed to do some additional setup via command line? Because I thought I can manage everything from GUI

You can do everything via GUI.
I think that you have a configuration problem in your network, but I can’t figure that out from the information you gave.
The only viable option I see is to offer to connect to your network to see what’s happening.


I already got where set.

In the network address and network mask must configure client network

I’ll try. What should I enter there? The address of the network where NS is sitting? So in my case
Or my network where my computer is connected currently (I am at home)

Btw. … what is the 128 at the end of the network mask? Why is it there? Because my network mask is

Thank you.

Your home mask, because which is connected, no?

I am at home. My home IP is within and I am connecting with my notebook to the NS.
The NS is in the company and the internal address is within,
So I suppose, to assure my computer is talking to other computers in the company network, I have to enter (to the fields you mentioned above) &, am I right?

Sorry the configuration is for 2 NS server.

If you use Win, you must run the openvpn client like administrator, other ways you never conect to the NS server.

I understand I have to save those settings to NS. But what should I save there?
Because till now I had this:

Now I have this

and when I try to connect with the second certificate, it connects, however I am even not able to reach the IP of NS.
When I used the first option (without any IP & mask), I could connect at least to the IP of NS.

Use this configuration if you want to connect two NS server.

Ah … I see. No I want to connect remote laptop (road warrior) to a NS and access the other computers on the local network.
I was just thinking … shouldn’t I have something filled in this tab

can you show me ,… advanced?

Please see post no. 6 in this thread

Thank you for the offer Filippo. I’ll try to re-install the NS during the weekend and based on the result, I’ll let you know.

We’re here to help


Good evening Gentlemen,
issue was solved. No idea what happened and where exactly the problem was, but after installing fresh copy of NS, doing basic setup like network, dhcp and VPN it started to work.
Anyway … thank you a lot for your support and for the great work you do for all of us using NS!


always made to order, for that we are @MarianH


Happy to see you have resolved! Welcome here. Can you please let us know what are you working on replying to this topic?