Cannot access computers on network when on VPN

Well … I think it is a NS problem … or to be precise … problem of some settings I’ve changed when did the initial setup.
So probably it will be better to do a fresh install one more time, do only basic setup like DHCP and then try the VPN.

Hope I’ll have some time during the weekend to do that. Will let you know how it went.

@MarianH where you are trying to connect it is a station windows, linux or mac.

I do not think it NethServer problem in any case reinstalls the package openvpn

As mentioned in on of my previous posts, I’ve checked this with two separate devices and 2 different certificates - notebook (windows 10) & mobile phone (android).
I have in both devices other connection to a different server running Zentyal and there are no issues to connect.

which software openvpn, are using the client station?

Could you please show the output of ip ro on NethServer?
And route print and windows 10.

1 Like

@MarianH @filippo_carletti I’ll be doing a test with a station Windows 10, using openvpn client

ping to client estation

my ip local

ping to other station client

Connection established without problems

I downloaded my user settings and all certificates, then place them in the folder OpenVPN configuration

1 Like

I am using OpenVPN 2.3.11 on the computer and 1.1.17 (build 76) core 3.0.12 on the android device.
When I did some tests yesterday, it is interesting that I can ping NS when on VPN. I can even login to the GUI on the green interface (administration on the red is not allowed)
I can as well ping 2 devices on red interfaces as well as login to them. However I cannot reach the devices on the LAN. So in some way I am allowed to reach the devices towards internet & NS as such, however I cannot reach devices on the LAN.

This is what I have when in VPN. I am on the

TAP adapter

Jose, I was just wondering … why have you put all certificates to the configuration folder please? Because I’ve got there only the .ovpn file and it is not asking for anything else. When I’ve give there the .pem as well, nothing changed

Hi Filippo,

sorry, I am quite new in Linux, so may I ask to to write it as for dummies please?
Should I connect to VPN, SSH to NS and write ip ro and then route print?
Or how should I do that please?

Thank you.

Of course, .ovpn is just data connection, and a single connection certificate included in the file

I place if needed, dont worry

Still I have connection and I can see the security cameras from my office using local ip of my client

@MarianH I’m using the OpenVPN version 2.3.11 released on 2016.05.10 later winvista an 64-bit

  1. connect via ssh to NS and type: ip ro
  2. on your windows, type: route print
1 Like

@MarianH to connect via ssh from terminal linux, you can use these commands:
ssh -p port set to ssh root@ip-nethserver, or ip-dynamic, or ip-public


OK, so let’s see if I did it right.
I’ve connected to the NS via OpenVPN. Then via PuttySSH I’ve used the ip ro command. The same I did with the cmd in Windows. The results are below.
At the end I’ve disconnected the VPN.

Hope that is the correct way of doing this.

I don’t see a default gateway in NS ip ro output.
On the windows output, I see, and, but it can be normal on windows, I don’t have past experience.
Could you show the output of db networks show?

@filippo_carletti this is my configuration if, serves them Help

[root@firewall-rmg ~]# ip ro dev tun0 proto kernel scope link src via dev tun0 dev eth0 proto kernel scope link src dev eth1 proto kernel scope link src dev eth0 scope link metric 1002 dev eth1 scope link metric 1003
default via dev eth1

you might have some misconfiguration in NethServer @MarianH

I configure OpenVPN to connect 2 ns 6.8, are connected sy pin can do the internal network of the vpn but not real ip.

The reason is that not observe the statement of the external network on my route in my ns server.

Within the / etc / openvpn / ccd, I do not see the configuration of the client connecting.

The current system configuration is correct?

PS: I can make settings manually and restart openvpn ??


Filippo, do you mean this:

Yes, thats what I think too. But I was not doing any changes, except those via GUI, because I am not really skilled with Linux yet. So it has to be only something I clicked (probably) and now it doesn’t work properly.

@filippo, i guess this is the configuration of yours NS, correct?

If I want to ping a server on the external network, I have to tell my NS which is the route, is the configuration is not that I observe.

Eth1 = ns?


Make a ip route ,and you can’t see the network of the remote site.

That is what I try to say